Opened 11 years ago

Closed 10 years ago

#2457 closed bug (fixed)

[Firefox] Link broken, and runtime_loader cannot open file libmozjs.so

Reported by: andreasf Owned by: axeld
Priority: normal Milestone: R1
Component: Applications Version: R1/pre-alpha1
Keywords: Cc: mattmadia@…
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

It's been a while that I've run Haiku and it used to work some weeks ago. Now with hrev26134, the link from the Applications menu is broken (the broken link icon, and message "There was an error resolving the link."), and when launching /boot/apps/firefox/firefox-bin from the Terminal I get:

runtime_loader: cannot open file libmozjs.so

Setting LD_LIBRARY_PATH=/boot/apps/firefox did not help. Re-running jam -q haiku-image led to the same results.

Change History (9)

comment:1 Changed 11 years ago by mmlr

That's probably because you're not running it from the correct working directory. When you launch from a Terminal you have to cd into the firefox directory first of course, otherwise the relative paths cannot be resolved. Double clicking should work, as should correcting and using the link.

comment:2 Changed 11 years ago by diver

IIRC you need to launch FF by "firefox" shell script and not by "firefox-bin".

comment:3 in reply to:  1 Changed 11 years ago by andreasf

Nope, I tried from within the directory.

What works though is deleting the downloaded Firefox.zip. With the newly downloaded zip it works just fine.

This means the problem is within the Optional Package definition, it always names the downloaded file Firefox.zip while virtually all other packages have versioned names (version and/or date) so that they are re-downloaded when necessary. Changing title to reflect this.

comment:4 in reply to:  2 Changed 11 years ago by andreasf

The new package is different, it goes to /boot/apps/Firefox and is named Firefox, therefore the broken link. The link points directly to Firefox, but there is also a run_mozilla.sh script.

comment:5 Changed 11 years ago by diver

This is how I start firefox which comes from OptionalPackage:

cd /boot/apps/firefox

./firefox

comment:6 Changed 10 years ago by tqh

Unless someone did some reordering in the optional package firefox-bin will always fail. firefox is the script that sets up libs and things for launch. (And yes we don't like it either).

comment:7 Changed 10 years ago by mmadia

Cc: mattmadia@… added

comment:8 Changed 10 years ago by andreasf

This issue has been resolved in the meantime. Please close the ticket.

comment:9 Changed 10 years ago by bonefish

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.