Opened 11 years ago

Closed 10 years ago

#2458 closed bug (fixed)

gcc4 build fails on haiku

Reported by: mt Owned by: axeld
Priority: normal Milestone: R1
Component: File Systems/BFS Version: R1/pre-alpha1
Keywords: Cc: andreas.faerber@…
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

I tried building native gcc4 (source from haiku tree) on Haiku. (hrev26134) But Build stops after fixinclude. From syslog, I thing file system issue has occur at fixinclude.

Attachments (6)

syslog.txt (77.2 KB ) - added by mt 11 years ago.
syslog file
gcclog.txt (245.2 KB ) - added by mt 11 years ago.
gcc build log
gdb.txt (1.1 KB ) - added by mt 11 years ago.
syslog2.txt (78.6 KB ) - added by mt 11 years ago.
gcclog2.txt (245.0 KB ) - added by mt 11 years ago.
gcclog4.txt (473.9 KB ) - added by mt 10 years ago.
gcc4 build log

Download all attachments as: .zip

Change History (14)

by mt, 11 years ago

Attachment: syslog.txt added

syslog file

by mt, 11 years ago

Attachment: gcclog.txt added

gcc build log

comment:1 by andreasf, 11 years ago

Cc: andreas.faerber@… added

comment:2 by mmlr, 11 years ago

The "KERN: bfs: inode at 2621836 is corrupt!" line would indicate that said inode is in fact corrupt. The could easily be from a damage filesystem because of crashes probably. Can you reproduce the same issue with a freshly initialized filesystem as well? I will try to do a GCC4 build and check if the same issues arise here.

comment:3 by mt, 11 years ago

Hi, mmlr.
I freshly initialize haiku's partition by DriveSetup (bone). and tried with hrev26144 (build on bone). In hrev26144, fixincl crashes and file system corrupts.

by mt, 11 years ago

Attachment: gdb.txt added

by mt, 11 years ago

Attachment: syslog2.txt added

by mt, 11 years ago

Attachment: gcclog2.txt added

comment:4 by scottmc, 10 years ago

Can this be closed yet? We have gcc4 now.

in reply to:  4 ; comment:5 by scottmc, 10 years ago

Replying to scottmc:

Can this be closed yet? We have gcc4 now.

I misread this one. But has anyone tried doing this since we got gcc4? That is, building a gcc4 haiku on a gcc4 haiku, and did it work?

in reply to:  5 comment:6 by jackburton, 10 years ago

Replying to scottmc:

Replying to scottmc:

Can this be closed yet? We have gcc4 now.

I misread this one. But has anyone tried doing this since we got gcc4? That is, building a gcc4 haiku on a gcc4 haiku, and did it work?

Isn't this what Michael did ?

comment:7 by mt, 10 years ago

Hi, I tested hrev29319 (gcc4/gcc2 hybrid), gcc-4.3.3-haiku-090129, and gcc4 source code hrev29320. 'make bootstrap' is failed, but fixinclude seems work fine.

by mt, 10 years ago

Attachment: gcclog4.txt added

gcc4 build log

comment:8 by mmlr, 10 years ago

Resolution: fixed
Status: newclosed

Jup, that's normal. The comparison method is not applicable to Haiku. The issue mentioned here has been tracked and fixed in #3476.

Note: See TracTickets for help on using tickets.