Opened 11 years ago

Closed 11 years ago

Last modified 9 years ago

#2464 closed bug (duplicate)

PANIC on a AMD64 machine

Reported by: xspager Owned by: axeld
Priority: normal Milestone: R1
Component: System/Kernel Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: #2284 Blocking:
Has a Patch: no Platform: x86

Description

Im booting Haiku on a GIGABYTE(GA-M61PM-S2) the socket is AM2 with AMD64 x2 (dual core), 2GB RAM, HD SATA. Im gettin the debug screen whit this message, that i hand copy:

PANIC: vm_page_fault: unhandled page fault in kernel space at 0x0, ip 0x0

Enabling the debug output on the boot menu the last line in the output is:

vm_soft_fault: kernel thread accessing invalid user memory
vm_page_fault: vm_soft_fault returned error 'Bad address' on fault at 0x0, ip 0x0, write 0, user 0, thread 0xa

and then the debug screen.

there also a screenshot of bt command output in attach

Attachments (1)

00003.jpg (43.8 KB) - added by xspager 11 years ago.
cam screenshot of bt output

Download all attachments as: .zip

Change History (10)

Changed 11 years ago by xspager

Attachment: 00003.jpg added

cam screenshot of bt output

comment:1 Changed 11 years ago by axeld

Component: - GeneralSystem/Kernel

Can you turn on on-screen console output in the boot loader (entered by pressing space very early in the boot process), and copy the last lines of output before it crashes?

comment:2 Changed 11 years ago by xspager

I`m building this using --build-cross-tools-gcc4

comment:3 Changed 11 years ago by xspager

From Gigabyte site

GA-M61PM-S2 Chipset

  1. NVIDIA® GeForce 6100 / nForce 430
  2. Super I/O chip: ITE IT8716
  3. Integrated Peripherals
    1. T.I. IEEE1394 controller
    2. Realtek RTL8211 Gigabit Ethernet controller
    3. Realtek ALC883 Audio Codec

comment:4 Changed 11 years ago by xspager

using linux32 and --build-cross-tools , crash too on boot

comment:5 in reply to:  1 Changed 11 years ago by dlmcpaul

Replying to axeld:

Can you turn on on-screen console output in the boot loader (entered by pressing space very early in the boot process), and copy the last lines of output before it crashes?

Here is what I get

Legacy SATA: controller found vendor 0x10de device 0x0055

Legacy SATA: controller probe

PCI-IDE: Controller in native mode cmd 0x9e0 ctrl 0xbe2 irq 11

PCI-IDE: init channel

PCI-IDE: channel index 0

PCI-IDE: bus master base 0xe800

PCI-IDE: init channel done

vm_soft_fault etc

comment:6 Changed 11 years ago by axeld

Blocked By: 2284 added
Resolution: duplicate
Status: newclosed

Thanks, that made it clear - it's a duplicate of bug #2284.

comment:7 Changed 11 years ago by xspager

ok! thanks, now it boots for me. Thank you very much, the last revision builded with gcc2 boots without comply any thing on normal boot.

comment:8 Changed 9 years ago by mmadia

Platform: x64x86-64

comment:9 Changed 9 years ago by bonefish

Platform: x86-64x86
Note: See TracTickets for help on using tickets.