Opened 11 years ago

Closed 5 years ago

#2495 closed enhancement (fixed)

[MediaPlayer] Pressing left/right arrows do unexpected things

Reported by: diver Owned by: nobody
Priority: normal Milestone: R1
Component: Applications/MediaPlayer Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Pressing left/right arrows when watching a movie in MediaPlayer do unexpected things like starts current movie again.
Some years ago I suggested hotkeys for BeOS port of VLC, which never been implemented. Those suggestions are still available in videolan wiki at http://wiki.videolan.org/BeOS, they could need some cleaning, but most of them should make MediaPlayer a pleasure to use already.

Change History (17)

comment:1 by diver, 10 years ago

Version: R1/pre-alpha1R1/Development

comment:2 by diver, 10 years ago

Also how about moving "No interface" to middle mouse button, leaving right click for context menu only. It's very confusing as it is now.

comment:3 by stippi, 10 years ago

The videolan Wiki link is no longer valid. Can you repeat your suggestions here, please?

The comment about the "No interface" option is invalid, IMHO. I don't understand what is confusing about it at all.

comment:4 by diver, 10 years ago

I've reworked it a bit:

Keyboard shortcuts:

UpVolume up
DownVolume down
LeftSeek 5 sec backward
RightSeek 5 sec forward
Alt+LeftSeek 30 sec backward
Alt+RightSeek 30 sec forward
Alt+AAlways On Top
Z, X, C, V, BPrev, Play, Pause, Stop, Next
PCapture frame - original image size
Shift+PCapture frame - "What you see"
MMute
JJump to time
Plus/MinusResize player window with video
HShow/Hide interface


Mouse actions:

Left button Pause/Resume movie
Right buttonContext menu
Middle buttonShow/Hide interface


Also it wold be nice if MediaPlayer would write attribute to media file about current playing time (on quit only perhaps), so that when you open same file (think of some movie) next time it will open right where you stopped watching it.

comment:5 by diver, 9 years ago

ping.

comment:6 by diver, 9 years ago

To reproduce:

  • open a video file
  • press left arrow
  • press Space to pause
  • press right

MediaPlayer will jump to the beginning of that file.

comment:7 by stippi, 9 years ago

Changed the meaning of the cursor left/right keys, as well as up/down and Cmd-A in hrev38594. More to come, but until I had a clever idea, it appeared to be insanely hard to get this right with regards to crossing over to the next/previous playlist item while winding, so I kinda took all day for something seemingly simple.

comment:8 by stippi, 9 years ago

Cmd-H, +/-, M and ZXCVB implemented in hrev38599. That leaves Cmd-J (which I consider unuseful bloat, since it's much easer to just drag the slider or even use the new left/right winding functionality), the screen shot shortcuts and the mouse actions. I don't think the mouse actions are useful either. Spacebar is much more intuitive and common for toggling play/pause and the middle mouse button to show/hide the interface may be somewhat unexpected. I think it's better to do such a potentially irritating action through a concious context menu invokation. That would leave the screenshot stuff and remembering of the last playing position (for movies) as the things I would like to implement before closing this ticket. What do you think, diver?

comment:9 by humdinger, 9 years ago

ZXCVB as control shortcuts are OK, I guess (though a 1:1 parallel to the buttons, i.e. X toggles play/pause instead of X==play, C==pause). However, I always fear to accidentally hit V==Stop and thereby rewinding a clip to the start, never finding the exact time I left off so abruptly...
(BTW, the stop button in general doesn't strike me as that useful and more like a vestigial remnant of tape decks.)

Anyway, could Alt+left/right be added as shortcut to jump to previous/next file? Together with the big spacebar to play/pause that would be much more intuitive IMO.

comment:10 by stippi, 9 years ago

Have you tried it? I thought Cmd-left/right already skip to the previous/next clips. In any case, it's supposed to work, and I thought I had tested it. Will have a look ASAP.

comment:11 by humdinger, 9 years ago

I'm sorry. ALT+left/right does work. Not sure what I did wrong before...

comment:12 by diver, 9 years ago

Replying to stippi:

That leaves Cmd-J (which I consider unuseful bloat, since it's much easer to just drag the slider or even use the new left/right winding functionality)


Agree.

I don't think the mouse actions are useful either. Spacebar is much more intuitive and common for toggling play/pause


If left mouse button is unused why don't assign some useful action to it.

the middle mouse button to show/hide the interface may be somewhat unexpected. I think it's better to do such a potentially irritating action through a concious context menu invokation.


It is hard to accidentally press middle mouse button, so I don't think it would irritate anyone. Currently it is very irritating when I try to open context menu and it somehow triggers "No interface" (which should also be renamed to "Hide interface").

That would leave the screenshot stuff and remembering of the last playing position (for movies) as the things I would like to implement before closing this ticket.

Some new hotkeys:

FFull screen switch*
Ctrl+1/2/3Change aspect ratio (Stream settings/4:3/16:9)
ACycle aspect ratios

*I think it is useful to have a single key to toggle full screen.

Anyway MediaPlayer is much more usable now, thanks a lot!

Replying to humdinger:

ZXCVB as control shortcuts are OK, I guess (though a 1:1 parallel to the buttons, i.e. X toggles play/pause instead of X==play, C==pause). However, I always fear to accidentally hit V==Stop and thereby rewinding a clip to the start, never finding the exact time I left off so abruptly...

I totally agree. I think we should get rid of Stop hotkey and make X toggles play/pause. Also all hotkeys should work in Playlist window as well (see #6562)

comment:13 by diver, 9 years ago

BTW, I recall that I used V to stop streaming online radio in Winamp, because if you pause streaming (C) and later continue playing (X) winamp would play several seconds from buffer and then it would need to reconnect to streaming server suddenly it plays some other song, which is a bit annoying.

comment:14 by halilpk, 8 years ago

Haiku revision: hrev42211 still a bug. When you press left/right arrow while watching video sometimes it works(Seek 5 sec backward/forward) but sometimes it do unexpected things like go to start/finish . System: Haiku hrev1-alpha3 on VMware workstation 8 on windows 7 32 bit

comment:15 by marcusoverhagen, 8 years ago

Owner: changed from marcusoverhagen to nobody
Status: newassigned

comment:16 by harvard, 7 years ago

Pressing left/right arrows does not do unexpected things,it just rewinds the video on pressing the left key and plays it faster on pressing the right key and if it reaches the end then goes on to play the next next movie in Haiku Alpha 4.1/R1

comment:17 by pulkomandy, 5 years ago

Resolution: fixed
Status: assignedclosed

Implemented in hrev48330 except "A" (cycle aspect ratios), which I think is not so useful and a bit more code to write.

Note: See TracTickets for help on using tickets.