Opened 11 years ago

Closed 11 years ago

#2502 closed bug (invalid)

svn checkout via ssh prompts for password several times

Reported by: anevilyak Owned by: bonefish
Priority: normal Milestone: R1
Component: Applications/Command Line Tools Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

If I try to do an svn co via svn+ssh using Michael Lotz's svn package + OpenSSH, it first asks me to accept the key like normal, but then asks for my password three times. This doesn't appear to be a negotiation failure since intentionally mistyping my password does result in it indicating a password error and re-prompting, while typing it correctly results in an additional prompt, but no warning/error. After typing it in three times, the checkout starts like it should. Anything that can be done to verify where the problem is here?

Change History (1)

comment:1 Changed 11 years ago by bonefish

Resolution: invalid
Status: newclosed

The same happens in Linux (tested with Subversion 1.4.4). svn seems to open three connections (or one connection three times). I seem to recall having read quite a while ago that they wanted to fix that. Obviously they haven't.

Note: See TracTickets for help on using tickets.