Opened 11 years ago

Closed 11 years ago

#2501 closed bug (duplicate)

Regression: USB Keyboard not Working on Lenovo T61

Reported by: bonefish Owned by: mmlr
Priority: normal Milestone: R1/alpha1
Component: Drivers/USB Version: R1/pre-alpha1
Keywords: Cc: marcusoverhagen
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

hrev26330

My USB keyboard doesn't work on my T61 anymore. When booting with the keyboard plugged into the laptop itself, the keyboard doesn't work. The USB mouse plugged into the docking station works as expected. When the keyboard is also plugged into the docking station neither keyboard nor mouse do work. Serial debug output for both situations attached.

I experienced a similar behavior quite a while ago, but at the point of closing #1764 everything worked like a charm. Apparently later changes broke things again.

Attachments (2)

serial-keyboard-in-laptop (92.5 KB ) - added by bonefish 11 years ago.
serial debug output -- keyboard plugged into laptop
serial-keyboard-in-docking-station (92.8 KB ) - added by bonefish 11 years ago.
serial debug output -- keyboard plugged into docking station

Download all attachments as: .zip

Change History (5)

by bonefish, 11 years ago

Attachment: serial-keyboard-in-laptop added

serial debug output -- keyboard plugged into laptop

by bonefish, 11 years ago

serial debug output -- keyboard plugged into docking station

comment:1 by bonefish, 11 years ago

BTW, I'll be bringing the hardware on Monday.

comment:2 by marcusoverhagen, 11 years ago

Cc: marcusoverhagen added

You can try to enable TRACE_PS2 in ps2_common.h to see if the usb mouse data is delivered by legacy emulation through the ps2 port.

You can also try to revert hrev22617 to see if the ps2 selftest command makes a difference.

comment:3 by mmlr, 11 years ago

Resolution: duplicate
Status: newclosed

This is in fact a duplicate of bug #1889 and fixed in hrev26552.

Note: See TracTickets for help on using tickets.