Opened 11 years ago

Closed 9 years ago

#2507 closed bug (fixed)

[NetPositive] crash after closing it's preferences window

Reported by: diver Owned by: axeld
Priority: normal Milestone: R1
Component: Servers/app_server Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

NetPositive crash after closing it's preferences window. Dunno if it reproducible.

[tcsetpgrp failed in terminal_inferior: Invalid Argument]
Thread 857 caused an exception: Segment violation
Reading symbols from /boot/beos/system/lib/libbe.so...(no debugging symbols found)...done.
Loaded symbols for /boot/beos/system/lib/libbe.so
Reading symbols from /boot/beos/system/lib/libnetwork.so...(no debugging symbols found)...done.
Loaded symbols for /boot/beos/system/lib/libnetwork.so
Reading symbols from /boot/beos/system/lib/libtracker.so...(no debugging symbols found)...done.
Loaded symbols for /boot/beos/system/lib/libtracker.so
Reading symbols from /boot/beos/system/lib/libtextencoding.so...(no debugging symbols found)...done.
Loaded symbols for /boot/beos/system/lib/libtextencoding.so
Reading symbols from /boot/beos/system/lib/libmidi.so...(no debugging symbols found)...done.
Loaded symbols for /boot/beos/system/lib/libmidi.so
Reading symbols from /boot/beos/system/lib/libmail.so...(no debugging symbols found)...done.
Loaded symbols for /boot/beos/system/lib/libmail.so
Reading symbols from /boot/beos/system/lib/libtranslation.so...(no debugging symbols found)...done.
Loaded symbols for /boot/beos/system/lib/libtranslation.so
Reading symbols from /boot/beos/system/lib/libgame.so...(no debugging symbols found)...done.
Loaded symbols for /boot/beos/system/lib/libgame.so
Reading symbols from /boot/beos/system/lib/libroot.so...done.
Loaded symbols for /boot/beos/system/lib/libroot.so
Reading symbols from /boot/beos/system/lib/libpng.so...done.
Loaded symbols for /boot/beos/system/lib/libpng.so
Reading symbols from /boot/beos/system/lib/libz.so...done.
Loaded symbols for /boot/beos/system/lib/libz.so
Reading symbols from /boot/beos/system/lib/libstdc++.r4.so...done.
Loaded symbols for /boot/beos/system/lib/libstdc++.r4.so
Reading symbols from /boot/beos/system/lib/libmidi2.so...done.
Loaded symbols for /boot/beos/system/lib/libmidi2.so
Reading symbols from /boot/beos/system/lib/libmedia.so...done.
Loaded symbols for /boot/beos/system/lib/libmedia.so
Reading symbols from /boot/beos/system/lib/libfluidsynth.so...done.
Loaded symbols for /boot/beos/system/lib/libfluidsynth.so
[tcsetpgrp failed in terminal_inferior: Invalid Argument]

[Switching to team /BeOS/beos/apps/NetPositive (784) thread w>Preferences (857)]
0x004ab213 in BView::~BView () from /boot/beos/system/lib/libbe.so
(gdb) bt
#0  0x004ab213 in BView::~BView () from /boot/beos/system/lib/libbe.so
#1  0x004625dc in BMenuField::~BMenuField ()
   from /boot/beos/system/lib/libbe.so
#2  0x004ab21f in BView::~BView () from /boot/beos/system/lib/libbe.so
#3  0x00496c0c in BTab::~BTab () from /boot/beos/system/lib/libbe.so
#4  0x004977c3 in BTabView::~BTabView () from /boot/beos/system/lib/libbe.so
#5  0x004ab21f in BView::~BView () from /boot/beos/system/lib/libbe.so
#6  0x00332561 in PrefsView::~PrefsView ()
#7  0x004ab21f in BView::~BView () from /boot/beos/system/lib/libbe.so
#8  0x004b5f1b in BWindow::~BWindow () from /boot/beos/system/lib/libbe.so
#9  0x00413796 in BLooper::Quit () from /boot/beos/system/lib/libbe.so
#10 0x004b662a in BWindow::Quit () from /boot/beos/system/lib/libbe.so
#11 0x00414e1f in BLooper::_QuitRequested ()
   from /boot/beos/system/lib/libbe.so
#12 0x0041331a in BLooper::DispatchMessage ()
   from /boot/beos/system/lib/libbe.so
#13 0x004b8ebd in BWindow::DispatchMessage ()
   from /boot/beos/system/lib/libbe.so
#14 0x004bc678 in BWindow::task_looper () from /boot/beos/system/lib/libbe.so
#15 0x0041488b in BLooper::_task0_ () from /boot/beos/system/lib/libbe.so
#16 0x009859c0 in thread_entry () from /boot/beos/system/lib/libroot.so
#17 0x70206fec in ?? ()
(gdb) 

Change History (4)

comment:1 Changed 10 years ago by diver

Could this be NetPositive bug, or it's BMenuField? I can't reproduce it btw

comment:2 Changed 9 years ago by jackburton

Can we close this ?

comment:3 Changed 9 years ago by diver

I think so.

comment:4 Changed 9 years ago by jackburton

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.