Opened 13 years ago

Closed 11 years ago

Last modified 10 years ago

#251 closed bug (fixed)

[Keymap] cpu usage and key images flickering

Reported by: diver Owned by: korli
Priority: low Milestone: R1
Component: Preferences/Keymap Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by korli)

This is very visible in vmware so try it here. Open Keymap and start pressing Alt key very fast (about 30 times). While you do it you could see key images flickering like hell. Tested with hrev16575.

Change History (9)

comment:1 Changed 13 years ago by korli

severity: normalminor

comment:2 Changed 13 years ago by diver

Summary: [Keymap] key images flickering[Keymap] cpu usage and key images flickering

comment:3 Changed 13 years ago by diver

OK, now i found the cause of this. Try running Pulse with Keymap and start pressing buttons. Soon you'll see that pressing Caps Lock, Shift, Control, Win, Alt and Space bar generates 100% cpu usage, while pressing all other buttins doesn't do it.

comment:4 Changed 13 years ago by johndrinkwater

Diver, the reason behind the problem is cause by caps/shift/alt/win being modifier keys, Keymap redraws each key because they could have a different key value.

(and still apparent in hrev17690)

comment:5 Changed 12 years ago by korli

Component: - Preferences- Preferences/Keymap
Description: modified (diff)
Platform: All

comment:6 Changed 11 years ago by aldeck

Resolution: fixed
Status: newclosed

fixed in hrev24110

comment:7 Changed 10 years ago by diver

Version: R1 development

New Keymap is having the same problems like in description, should I reopen this bug, or create a new one?

comment:8 in reply to:  7 Changed 10 years ago by aldeck

Replying to diver:

New Keymap is having the same problems like in description, should I reopen this bug, or create a new one?

Nope, as this is a totally new/different drawing code (work in progress even, so i'd wait a bit before submitting any new bug on this). My old drawing rewrite/optimisation now Rests.In.Peace :D

comment:9 Changed 10 years ago by axeld

Don't worry, aldeck, I will put that back in - I just developed it in VESA mode and didn't even notice any flickering there :-)

I think we should really have double buffering built in, though...

Note: See TracTickets for help on using tickets.