Opened 14 years ago

Closed 13 years ago

#252 closed bug (invalid)

[Deskbar] crash on shutdown

Reported by: diver Owned by: jackburton
Priority: normal Milestone: R1
Component: - General Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by jackburton)

Dunno if it reproducable, but anyway. I've edited some config file and tried to shutdown. As i use it in vmware there was a minute with "tiding things up a bit" message (it's a http://www.haiku-os.org/bugzilla/show_bug.cgi?id=104). Then i pressed Cancel shutdown button and then Deskbar crashed. Screenshot will follow. Tested with hrev16575.

Attachments (2)

deskbar_crash.PNG (28.2 KB ) - added by diver 14 years ago.
debug output
deskbar.PNG (10.7 KB ) - added by diver 13 years ago.
BeMenu

Download all attachments as: .zip

Change History (10)

by diver, 14 years ago

Attachment: deskbar_crash.PNG added

debug output

comment:1 by jackburton, 13 years ago

Owner: changed from bpmagic@… to jackburton

comment:2 by jackburton, 13 years ago

This shouldn't happen anymore. Can you confirm ?

comment:3 by diver, 13 years ago

There is still some issues left: Try to click several times on Deskbar while shutdown and then cancel shutdown. If you do it in vmware you could also drag shutdown window around to see app_server freeze. After a minute app_server will unfreeze, but deskbar will be locked up. Screenshot will follow. Tested with rev16917 under vmware.

by diver, 13 years ago

Attachment: deskbar.PNG added

BeMenu

comment:4 by diver, 13 years ago

Cc: axeld@… added

comment:5 by lothalev@…, 13 years ago

Not crashing in 17592, though shutdown is not working. Clicking cancel and then selecting Reboot (after system shutdown window unfreezes;) works correctly

comment:6 by jackburton, 13 years ago

Shutdown works correctly here. Can you still reproduce ?

comment:7 by diver, 13 years ago

Current behavior is this: If you change something on haiku partition under vmware and try to shutdown/ reboot you will end up with "Tiding things up a bit" message for a half of a minute due to #104. If you press Cancel button this message will stay until half of a minute to end. Now if you drag this window over Deskbar you could see that deskbar and _only_ deskbar is frozen, you can control any other window. In the end of that delay Deskbar will with us again.

Should i close this bug and open another one with this description, Stefano?

comment:8 by jackburton, 13 years ago

Description: modified (diff)
Platform: All
Resolution: invalid
Status: newclosed

Doesn't happen anymore. Just tested with latest revision.

Note: See TracTickets for help on using tickets.