Opened 11 years ago

Closed 11 years ago

#2520 closed bug (fixed)

could not create mutexError: Unexpected end of fs_shell reply. Was still expecting 4 bytes

Reported by: kaliber Owned by: axeld
Priority: normal Milestone: R1
Component: - General Version: R1/pre-alpha1
Keywords: Cc: haiku@…
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

On linux I am copying additional files to the haiku.image from late-image-script. I got error:

cp -r generated/tmp/root/common /myfs/
could not create mutexError: Unexpected end of fs_shell reply. Was still expecting 4 bytes
cp -r generated/tmp/root/home /myfs/
Error: Failed to open connection to FS shell: Connection refused
./build/scripts/late-image-script.sh: line 56: 28328 Segmentation fault      $bfsShell -n $imageOffsetFlags "$imagePath" > /dev/null
cp -r generated/tmp/root/var /myfs/
Error: Failed to open connection to FS shell: Connection refused

Change History (2)

comment:1 Changed 11 years ago by scottmc

Cc: haiku@… added

I get something similar when trying to add extra zip files to my images:

Unzipping generated/download/automake-1.10.1-gcc2-2008-03-24-1.zip ...
could not create mutexError: Unexpected end of fs_shell reply. Was still expecting 4 bytes
Unzipping generated/download/bison-2.3-gcc2-2008-03-28.zip ...
Error: Failed to open connection to FS shell: Connection refused
Unzipping generated/download/flex-2.5.35-gcc2-2008-03-28.zip ...
Error: Failed to open connection to FS shell: Connection refused

comment:2 Changed 11 years ago by axeld

Resolution: fixed
Status: newclosed

Fixed in hrev26816; bug #2561 is actually a duplicate of this one.

Note: See TracTickets for help on using tickets.