Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#2561 closed bug (fixed)

bfs_shell no more sems

Reported by: mrsunshine Owned by: axeld
Priority: normal Milestone: R1
Component: - General Version: R1/pre-alpha1
Keywords: Cc: mrsunshine
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

bfs_shell when copying lots of files crashes with no more sems error (tested by printf)

backtrace:

#0 0x0806d0e6 in fssh_panic ()
#1 0x0806dcd5 in fssh_mutex_init ()
#2 0x0806c7ce in fssh_file_cache_create ()
#3 0x0805c6f6 in Inode::Create ()
#4 0x0806922c in bfs_create ()
#5 0x08072b36 in FSShell::create_vnode ()
#6 0x08074fb7 in FSShell::_kern_open ()
#7 0x0807c54f in FSShell::GuestFSDomain::CreateFile ()
#8 0x0807a4ea in FSShell::copy_entry ()
#9 0x0807abe7 in FSShell::copy_dir_contents ()
#10 0x0807a973 in FSShell::copy_entry ()
#11 0x0807abe7 in FSShell::copy_dir_contents ()
#12 0x0807a973 in FSShell::copy_entry ()
#13 0x0807abe7 in FSShell::copy_dir_contents ()
#14 0x0807a973 in FSShell::copy_entry ()
#15 0x0807abe7 in FSShell::copy_dir_contents ()
#16 0x0807a973 in FSShell::copy_entry ()
#17 0x0807abe7 in FSShell::copy_dir_contents ()
#18 0x0807a973 in FSShell::copy_entry ()
#19 0x0807b4ba in FSShell::command_cp ()
#20 0x08075a5f in FSShell::Command::Do ()
#21 0x080788a5 in main ()

Change History (4)

comment:1 Changed 11 years ago by kaliber

Duplicate of bug #2520

comment:2 Changed 11 years ago by bonefish

Resolution: fixed
Status: newclosed

I increase the maximal number of semaphores in hrev26816. This should at least last a little bit longer.

comment:3 Changed 11 years ago by kaliber

Please close also bug #2520

comment:4 Changed 11 years ago by axeld

Thanks for the note!

Note: See TracTickets for help on using tickets.