Opened 11 years ago

Closed 11 years ago

#2527 closed bug (duplicate)

PANIC: vm_page_fault: unhandled page fault in kernel space at 0x1001004, ip 0x8004fafb

Reported by: anevilyak Owned by: bonefish
Priority: high Milestone: R1
Component: Drivers/TTY Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I went to open a file in vim, and then hit page down, and was greeted by the KDL in the subject line. Backtrace is as follows

<snip>kernel_debugger_stuff
<kernel>:panic + 0x0029
<kernel>:vm_page_fault + 0x00b1
<kernel>:page_fault_exception + 0x00b1
<kernel>:int_bottom + 0x0036 (nearest)
iframe at 0xa11efb9c (end = 0xa11efbf4)
eax 0x1001000 ebx 09x13d1040 ecx 0x0 edx 0x913d1040
esi 0x1 edi 0x80992060 ebp 0xa11efc04 esp 0xa11efbd0
eip 0x8004fafb eflags 0x10206
vector: 0xe, error code: 0x0
<kernel>:notify_select_events + 0x001b
<kernel>:notify_select_event + 0x0027
<kernel>:notify_select_event_pool + 0x005c
</boot/beos/system/add-ons/kernel/drivers/tty>:tty_notify_select_event__FP3ttyUc + 0x0031
</boot/beos/system/add-ons/kernel/drivers/tty>:tty_notify_if_available__FP3ttyT0b + 0x0085
</boot/beos/system/add-ons/kernel/drivers/tty>:_._12ReaderLocker + 0x0069
</boot/beos/system/add-ons/kernel/drivers/tty>:tty_input_read__FP10tty_cookiePvPUl + 0x04cc
</boot/beos/system/add-ons/kernel/drivers/tty>:slave_read__FPvxT0Pul + 0x0027
<kernel>:devfs_read__FP9fs_volumeP8fs_vnodePvxT2PUl + 0x017b
<kernel>:file_read__FP15file_descriptorxPVPul + 0x0044
<kernel>:common_user_io__FixPvUlb + 0x017d
<kernel>:_user_read + 0x0028
<kernel>:pre_syscall_debug_done + 0x0002 (nearest)
iframe at 0xa11effa8 (end = 0xa11f0000)
eax 0x7c ebx 0x633e48 ecx 0x70080f40 edx 0xffff0104
esi 0x343cb8 edi 0x0 ebp 0x70080f7c esp 0xa11effdc
eip 0xffff0104 eflags 0x203
vector: 0x63, error code: 0x0
25 a11effa8 (+ 0) ffff0104
26 70080f7c (+48) 00318fa0 <_APP_>:OpenPTY + 0x01a0 (nearest)
27 70080fac (+48) 005abac0 <libroot.so:>:_get_next_team_info + 0x005c (nearest)
28 70080fdc (+ 0) 70080fec 122723:vim_async_read_4651_stack@0x70041000 + 0x33fec

I'm not sure how easy this will be to replicate as I've used vim quite a bit and never seen this one before, but will let you know if I find a consistent way to duplicate it.

Change History (1)

comment:1 Changed 11 years ago by bonefish

Resolution: duplicate
Status: newclosed

Duplicate of #2223.

Note: See TracTickets for help on using tickets.