Opened 11 years ago

Closed 11 years ago

#2223 closed bug (duplicate)

KDL in tty driver (rev. 25445)

Reported by: kaliber Owned by: bonefish
Priority: high Milestone: R1
Component: Drivers/TTY Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: #3126 Blocking:
Has a Patch: no Platform: All

Description (last modified by bonefish)

vm_soft_fault: va 0xdeadbef3 not covered by area in address space
vm_page_fault: vm_soft_fault returned error 'Bad address' on fault at 0xdeadbef3, ip 0x80045773, write 0, user 0, thread 0x24f5
PANIC: vm_page_fault: unhandled page fault in kernel space at 0xdeadbef3, ip 0x80045773

Welcome to Kernel Debugging Land...
Running on CPU 0
kdebug> 
kdebug> bt
stack trace for thread 9461 "w>Terminal 1"
    kernel stack: 0x977b4000 to 0x977b8000
      user stack: 0x70082000 to 0x700c2000
frame            caller     <image>:function + offset
977b7730 (+  48) 80048dab   <kernel>:invoke_debugger_command + 0x00cf
977b7760 (+  64) 80049b54   <kernel>:_ParseCommand__16ExpressionParserRi + 0x01f8
977b77a0 (+  48) 80049546   <kernel>:EvaluateCommand__16ExpressionParserPCcRi + 0x01de
977b77d0 (+ 224) 8004ac68   <kernel>:evaluate_debug_command + 0x0088
977b78b0 (+  64) 800478e6   <kernel>:kernel_debugger_loop__Fv + 0x017a
977b78f0 (+  48) 80048599   <kernel>:kernel_debugger + 0x010d
977b7920 (+ 192) 80048481   <kernel>:panic + 0x0029
977b79e0 (+  64) 800935a7   <kernel>:vm_page_fault + 0x00ab
977b7a20 (+  64) 8009d675   <kernel>:page_fault_exception + 0x00b1
977b7a60 (+  12) 800a0d4d   <kernel>:int_bottom + 0x001d (nearest)
iframe at 0x977b7a6c (end = 0x977b7ac4)
 eax 0xdeadbeef     ebx 0x90c8d880      ecx 0x0          edx 0x90c8d880
 esi 0x1            edi 0x801cc0a8      ebp 0x977b7ad4   esp 0x977b7aa0
 eip 0x80045773  eflags 0x10282    
 vector: 0xe, error code: 0x0
977b7a6c (+ 104) 80045773   <kernel>:notify_select_events + 0x001b
977b7ad4 (+  32) 8004581b   <kernel>:notify_select_event + 0x0027
977b7af4 (+  64) 80045c40   <kernel>:notify_select_event_pool + 0x005c
977b7b34 (+  48) 801c5f45   </boot/beos/system/add-ons/kernel/drivers/dev/tty>:tty_notify_select_event__FP3ttyUc + 0x0031
977b7b64 (+  48) 801c5fd1   </boot/beos/system/add-ons/kernel/drivers/dev/tty>:tty_notify_if_available__FP3ttyT0b + 0x0085
977b7b94 (+  48) 801c4ef3   </boot/beos/system/add-ons/kernel/drivers/dev/tty>:_._12WriterLocker + 0x0067
977b7bc4 (+ 208) 801c7a1d   </boot/beos/system/add-ons/kernel/drivers/dev/tty>:tty_write_to_tty_master_unsafe__FP10tty_cookiePCcPUl + 0x0469
977b7c94 (+ 320) 801c7b5d   </boot/beos/system/add-ons/kernel/drivers/dev/tty>:tty_write_to_tty_master__FP10tty_cookiePCvPUl + 0x0089
977b7dd4 (+  48) 801c9093   </boot/beos/system/add-ons/kernel/drivers/dev/tty>:master_write__FPvxPCvPUl + 0x0027
977b7e04 (+ 128) 80067b20   <kernel>:devfs_write__FP9fs_volumeP8fs_vnodePvxPCvPUl + 0x0178
977b7e84 (+  64) 8007955a   <kernel>:file_write__FP15file_descriptorxPCvPUl + 0x0036
977b7ec4 (+  80) 80069fe9   <kernel>:common_user_io__FixPvUlb + 0x017d
977b7f14 (+  48) 8006a4dc   <kernel>:_user_write + 0x0028
977b7f44 (+ 100) 800a0ec2   <kernel>:pre_syscall_debug_done + 0x0002 (nearest)
iframe at 0x977b7fa8 (end = 0x977b8000)
 eax 0x78           ebx 0x81aaec        ecx 0x700c1c90   edx 0xffff0104
 esi 0x22740b       edi 0x22740d        ebp 0x700c1ccc   esp 0x977b7fdc
 eip 0xffff0104  eflags 0x203      
 vector: 0x63, error code: 0x0
977b7fa8 (+   0) ffff0104
700c1ccc (+  48) 00216e7a   <_APP_>:Write__5ShellPCvUl + 0x002e
700c1cfc (+  80) 0021fa1a   <_APP_>:KeyDown__8TermViewPCcl + 0x03b2
700c1d4c (+ 464) 00385ceb   <libbe.so>:DispatchMessage__7BWindowP8BMessageP8BHandler + 0x0aef
700c1f1c (+  96) 00389fc4   <libbe.so>:task_looper__7BWindow + 0x0270
700c1f7c (+  48) 002e2ed3   <libbe.so>:_task0___7BLooperPv + 0x003f
700c1fac (+  48) 00795030   <libroot.so>:_get_next_team_info + 0x005c (nearest)
700c1fdc (+   0) 700c1fec   196701:w>Terminal 1_9461_stack@0x70082000 + 0x3ffec
kdebug> 

Change History (7)

comment:1 Changed 11 years ago by axeld

Component: - GeneralDrivers/TTY
Owner: changed from axeld to bonefish

comment:2 Changed 11 years ago by bonefish

Please give the revision number and the circumstances under which that happened.

comment:3 in reply to:  2 ; Changed 11 years ago by kaliber

Replying to bonefish:

Please give the revision number and the circumstances under which that happened.

Please read the title again - revision 25445 :) I was starting another terminal window (Ctrl-N)

comment:4 in reply to:  3 ; Changed 11 years ago by bonefish

Replying to kaliber:

Replying to bonefish:

Please give the revision number and the circumstances under which that happened.

Please read the title again - revision 25445 :)

Oh, sorry, totally overlooked that. BTW, it's nicer to have the revision number in the description and prefixed with "r" (hrev25445), so that Trac automatically hyperlinks it to the revision.

I was starting another terminal window (Ctrl-N)

Tried to reproduce it, but without success so far.

comment:5 in reply to:  4 Changed 11 years ago by kaliber

I was starting another terminal window (Ctrl-N)

Tried to reproduce it, but without success so far.

I also cannot reproduce it, sorry. I try to better describe situation. I had 2 open terminals:

  1. Compiling something (using autotools) and redirecting an output to the file.txt
  2. tail -f file.txt

comment:6 Changed 11 years ago by bonefish

Description: modified (diff)
Priority: normalhigh

#2557 is a duplicate of this one. The bug apparently still persists.

comment:7 Changed 11 years ago by axeld

Blocked By: 3126 added
Resolution: duplicate
Status: newclosed

Duplicate of #3126 which contains a reliable method on how to reproduce it.

Note: See TracTickets for help on using tickets.