Opened 13 years ago

Closed 11 years ago

#254 closed bug (fixed)

Wrongly enabled buttons in apps/prefs (easy)

Reported by: diver Owned by: aldeck
Priority: low Milestone: R1
Component: Applications Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by wkornewald)

There are several apps/prefs which enable some buttons on the first start, when i didn't change anything. Here is this list:

Fonts - Default
Keyboard - Default
Keymap - Revert, Use
Mouse - Default
Scroll Bar - Default
Virtual memory - Default

Also, when you start Sounds, you could see how butons becomes disabled Sounds - Play, Stop.

Attachments (5)

Anxiety - Ticket 254 - 20070816.diff (16.4 KB) - added by anxiety 12 years ago.
Diff file
20070816 - Ticket 254b.diff (1.1 KB) - added by anxiety 12 years ago.
Diff file, sounds disables correctly in this one
20070819 - Ticket 254c.diff (16.0 KB) - added by anxiety 12 years ago.
Diff file, contains changes for Appearance, Menu, and Tracker
menu.diff (16.0 KB) - added by aldeck 11 years ago.
Menu preflet should behave correctly with this.
menu2.diff (606 bytes) - added by aldeck 11 years ago.
Corrects a little mistake in menu/ColorWindow.cpp

Download all attachments as: .zip

Change History (33)

comment:1 Changed 13 years ago by axeld

Owner: changed from sikosis to axeld

comment:2 Changed 13 years ago by korli

bug_group: developers

comment:3 Changed 13 years ago by axeld

Description: modified (diff)
Platform: All
Priority: normallow

comment:4 Changed 13 years ago by axeld

Description: modified (diff)

comment:5 Changed 12 years ago by wkornewald

Description: modified (diff)

Screen should work correctly after my changes.

comment:6 Changed 12 years ago by wkornewald

Summary: Wrongly enabled buttons in apps/prefsWrongly enabled buttons in apps/prefs (easy)

Changed 12 years ago by anxiety

Diff file

comment:7 Changed 12 years ago by anxiety

I've attached a diff file that fixes the behavior of the default buttons, and hopefully handles the sounds issue satisfactory.

I did not make any changes to Keymap as the revert button doesn't do anything at all (with a note saying the original did not do anything either.) Perhaps that would be a good candidate for its own ticket?

Changed 12 years ago by anxiety

Attachment: 20070816 - Ticket 254b.diff added

Diff file, sounds disables correctly in this one

comment:8 Changed 12 years ago by axeld

Indeed, I think Keymap deserves its own ticket. Thanks!

comment:9 Changed 12 years ago by axeld

Resolution: fixed
Status: newclosed

And since ScrollBar has been removed, I'm closing this ticket now. Fixed in hrev21992.

comment:10 Changed 12 years ago by diver

Resolution: fixed
Status: closedreopened

Oh yeah, E-mail pref app still need to be fixed, it was not in the image a year ago, so it didn't made up in this list in the first place.

comment:11 Changed 12 years ago by diver

Also add to this list: Menu Screen Tracker Preferences

comment:12 Changed 12 years ago by diver

Oops, i forgot about Appearance... So it must be

Appearance E-mail Menu Screen Tracker Preferences

Changed 12 years ago by anxiety

Attachment: 20070819 - Ticket 254c.diff added

Diff file, contains changes for Appearance, Menu, and Tracker

comment:13 Changed 12 years ago by anxiety

I was able to get Appearance, Menu and Tracker working. Screen seems to work fine as long as the screen isn't in VESA mode. When in VESA there seems to be something going on with the refresh rate, but I wasn't able to figure out what. Email is going to take me some time as its more complex.

After looking at tracker, I think the majority of pref apps could benefit from using a consistent settings setup like tracker has.

comment:14 Changed 12 years ago by axeld

Thanks! In case you didn't notice, your patch was applied in hrev22049.

comment:15 Changed 12 years ago by diver

I found some problems: Menu: Selecting "Ctrl as Shortcut key" and back doesn't disable Revert button.

Tracker preferences: Selecting "Show Volumes on Desktop" (which is default) enables Default button. This could be seen only once, to reproduce you have to reboot.

And Background have Revert and Apply enabled.

Changed 11 years ago by aldeck

Attachment: menu.diff added

Menu preflet should behave correctly with this.

comment:16 Changed 11 years ago by aldeck

I hope that my patch is ok, i could have gone further in encapsulating all menu_info calls in the MenuSettings class and factoring/cleaning here and there, but i didn't want to make too much changes in one shot.

Going on to check the Screen preflet revert button, which should be disabled on start.

comment:17 Changed 11 years ago by stippi

Works great, thanks a lot! Menu patch applied in hrev23296.

comment:18 in reply to:  17 Changed 11 years ago by aldeck

Replying to stippi:

Works great, thanks a lot! Menu patch applied in hrev23296.

You're welcome! Thanks for the quick code review :)

Changed 11 years ago by aldeck

Attachment: menu2.diff added

Corrects a little mistake in menu/ColorWindow.cpp

comment:19 Changed 11 years ago by aldeck

menu2.diff applied in hrev23708

comment:20 Changed 11 years ago by diver

There is still a problem with Tracker preferences.

comment:21 in reply to:  20 Changed 11 years ago by aldeck

Replying to diver:

There is still a problem with Tracker preferences.

Didn't have much time these days. I just found the problem for Tracker settings. Will commit soon :-) Screen and Keymap still need some work though.

comment:22 Changed 11 years ago by aldeck

Tracker settings Revert/Default buttons should now behave corectly with hrev24008. Note that Mount Settings can't be defaulted/reverted though, since it's handled quite differently.

comment:23 Changed 11 years ago by aldeck

Owner: changed from axeld to aldeck
Status: reopenednew

comment:24 Changed 11 years ago by aldeck

Keymap is fixed now! hrev24180

comment:25 Changed 11 years ago by aldeck

Screen should be fixed! hrev24280

comment:26 Changed 11 years ago by diver

There are still problems with Background.

comment:27 Changed 11 years ago by diver

This bug could be closed as Background problems are documented in bug #1006

comment:28 Changed 11 years ago by aldeck

Resolution: fixed
Status: newclosed

Ok! Thanks for testing :)

Note: See TracTickets for help on using tickets.