Opened 11 years ago

Closed 11 years ago

#2580 closed bug (fixed)

Error in BFS when trying to initialize a partition with DriveSetup.

Reported by: bga Owned by: axeld
Priority: high Milestone: R1/alpha1
Component: File Systems/BFS Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I added a second virtual HD to my VMWare configuration by simply duplicating the Haiku disk image and assigned it as a slave IDE device on the first IDE controller.

I then booted Haiku in VMWare and, as expected it saw the 2 devices and a "Haiku" BFS partition in each.

I tried to use DriveSetup to initialize the second partition (it was not mounted, of course) and got the error in the attached KDL screenshot.

Attachments (1)

kdl.png (23.5 KB) - added by bga 11 years ago.
BFS crash when initializing partition.

Download all attachments as: .zip

Change History (4)

Changed 11 years ago by bga

Attachment: kdl.png added

BFS crash when initializing partition.

comment:1 Changed 11 years ago by bga

I went ahead and tried with mkfs just in case. As I expected, the same error happens.

comment:2 Changed 11 years ago by axeld

Milestone: R1R1/alpha1
Status: newassigned

comment:3 Changed 11 years ago by axeld

Resolution: fixed
Status: assignedclosed

Fixed in hrev26865.

Note: See TracTickets for help on using tickets.