Opened 11 years ago

Closed 11 years ago

#2583 closed bug (duplicate)

Mounted partitions other than boot get a cabinet icon instead of the disk icon.

Reported by: bga Owned by: stippi
Priority: low Milestone: R1
Component: User Interface Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Not sure if this is intentional or not, but I expected other mounted partitions to get the disk icon (without the leaf in the boot disk) but they show the cabinet icon instead.

Attachments (1)

custom_volume_icon.png (183.0 KB ) - added by stippi 11 years ago.
Custom volume icons are possible (persistent).

Download all attachments as: .zip

Change History (8)

comment:1 by stippi, 11 years ago

The problem is that drivers currently don't return HVIF icons. Either we introduce a new ioctl API for drivers to return HVIF icons and enable the code that reads those icons from drivers (BPartition and/or BVolume), or we decide to handle this differently altogether, for example by using built-in icons in Tracker based on volume properties.

comment:2 by bga, 11 years ago

By drivers you mean the fs add-ons, right? What we ended up doing in Zeta was to include the icons in Tracker itself (although they were loaded from external files). We went as far as having different icons (actually an icon plus a badge) for different file systems. i guess we could simply change the cabinet icon to be a disk icon? This looks more consistent to me.

OTOH, it would be cool if the file systems would export their icons (so they could have customized icons) and we only used the default one when no icon was exported. of course someone would have to implement this although it would probably be easier than actually designing the icons :).

comment:3 by stippi, 11 years ago

It is the device drivers actually, like the floppy or scsi_cd drivers.

The custom icon trick is still possible (I just checked). In case of BFS, I believe the root folder of the volume gets an icon attribute. This was even still possible in ZETA, I used this trick to give the WonderBrush CD a custom SVG icon.

by stippi, 11 years ago

Attachment: custom_volume_icon.png added

Custom volume icons are possible (persistent).

comment:4 by axeld, 11 years ago

Resolution: fixed
Status: newclosed

Fixed in hrev27001.

comment:5 by bga, 11 years ago

Resolution: fixed
Status: closedreopened

Actually, it is not. Just tried with an Audio CD and although the Mount menu now shows the CD icon, the icon in the Desktop is still the cabinet one.

comment:6 by scottmc, 11 years ago

This is a dupe of #1867

comment:7 by axeld, 11 years ago

Resolution: duplicate
Status: reopenedclosed
Note: See TracTickets for help on using tickets.