Opened 11 years ago

Closed 11 years ago

#2587 closed bug (invalid)

USB Boot Panic: could not mount boot device

Reported by: psudobuddha Owned by: axeld
Priority: normal Milestone: R1
Component: - General Version: R1/pre-alpha1
Keywords: Cc: briandabrain@…
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Experienced on a D520 Dell Latitude Laptop. It at first panics with a NMI interupt, then panics when makes it to the disk icon. Cant get debug output but will provide pictures of screen output as well as bt.

Attachments (2)

DELL-D620-booting-USB-Key-Manette-080811.txt (44.7 KB) - added by Manette 11 years ago.
Dell D620 booting from USB - Panic could not mount boot device
FlashNul-Too-Little-USB-Key-Manette-080811.txt (2.6 KB) - added by Manette 11 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 11 years ago by psudobuddha

Cc: briandabrain@… added

Changed 11 years ago by Manette

Dell D620 booting from USB - Panic could not mount boot device

comment:2 Changed 11 years ago by Manette

Same issue here with a Dell D620 and a Fujitsu S7020. (Cannot check for the NMI thing tough)

I flashnul'ed my 256 MB Kingston key with revision 26922. Either on my Dell D620 Laptop or on the Fujitsu-Siemens S7020 I receive a "Could not mount boot device" in a pretty Kernel Panic :-).

I got a serial debug output for the Dell one (not on Fujitsu because no built-in serial port...).

Please find attached to the ticked the serial debug output for the Dell. This problem is reproducible so feel free to ask me for some commands outputs if required.

Regards,

Emmanuel "Manette" Jacobs

comment:3 in reply to:  2 ; Changed 11 years ago by mmlr

Replying to Manette:

I flashnul'ed my 256 MB Kingston key with revision 26922. Either on my Dell D620 Laptop or on the Fujitsu-Siemens S7020 I receive a "Could not mount boot device" in a pretty Kernel Panic :-).

I got a serial debug output for the Dell one (not on Fujitsu because no built-in serial port...).

That debug output looks fine up to and including detecting the devices and partitions/filesystems. It shows that the USB device is recognized and the BFS filesystem on it is detected as well. Then mounting of that filesystem fails however. From the output it seems that this device has 245.5MB of space available. But the content size (the size the BFS reports) is exactly 250MB. So looking at the output you see that there are 4.5MB more that BFS expects but didn't fit on the device. Did you get any errors when writing the image? It looks like your device is sadly just 4.5MB too small. That's a bit unfortunate because you would need to build your own image to change the image size. We should make smaller images available, but right now you are a bit out of options with that device, sorry.

comment:4 in reply to:  3 Changed 11 years ago by Manette

Replying to mmlr: 8< snip !

That debug output looks fine up to and including detecting the devices and partitions/filesystems. It shows that the USB device is recognized and the BFS filesystem on it is detected as well. Then mounting of that filesystem fails however. From the output it seems that this device has 245.5MB of space available. But the content size (the size the BFS reports) is exactly 250MB. So looking at the output you see that there are 4.5MB more that BFS expects but didn't fit on the device. Did you get any errors when writing the image? It looks like your device is sadly just 4.5MB too small. That's a bit unfortunate because you would need to build your own image to change the image size. We should make smaller images available, but right now you are a bit out of options with that device, sorry.

Thanks for the hint... I'll attach a second text file showing Flashnul issue no error on this case... Maybe adding some kind of warning about that in the published text may be of interest ?

Thanks for having checked this issue ! :-)

comment:5 Changed 11 years ago by psudobuddha

After a quick check, I too have the same problem, but I have a cygwin gcc4 build env and will test to see if adjusting the image size fixes anything.

comment:6 Changed 11 years ago by psudobuddha

That was the problem, so I say there was no bug, as a smaller image booted perfectly

comment:7 Changed 11 years ago by mmlr

Resolution: invalid
Status: newclosed

Nice, thanks for the update. In that case I'm closing this as invalid as there was no bug. I have written a proposal to the development list to slightly reduce the default image size (http://www.freelists.org/archives/haiku-development/08-2008/msg00267.html). This should help most of the cases where a device is just a few MBs too small.

Note: See TracTickets for help on using tickets.