Opened 11 years ago

Closed 7 years ago

Last modified 14 months ago

#2588 closed bug (invalid)

Boot error on Gigabyte N211U notebook

Reported by: dancso.robert Owned by: axeld
Priority: normal Milestone: R1
Component: System/Boot Loader Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

After the BIOS boot process the system hangs up. No boot logo, no error messages, no nothing. This is the same on the Zeta. Only BeOS can boot up with the original zbeos. If it want to change the screen to bigger than 640x480x8 (if I use a custom boot logo), or I want to enter the boot menu (using space or the ALT) it hangs up too during boot. So, I cannot try the Haiku on my notebook. On my desktop PC (Shuttle SK21G, 384 MB RAM, SATA HDD, AMD Sempron 2800+) it is works as design.

Change History (12)

comment:1 by mmlr, 11 years ago

How have you installed Haiku and what boot manager are you using? Are there other operating systems installed and do they boot as expected? You can take a look at http://www.haiku-os.org/documents/user/how_to_get_haiku_booted and see if this helps.

comment:2 by dancso.robert, 11 years ago

Hello!

I have BeOS R5 Pro and Windows XP Home on my notebook. I installed Haiku from an image-file from the BeOS to a blank partition: mount haiku-image, and copy everything to the blank bfs volume, made bootable the Haiku, and I tried to use the BeOS boot manager, and without that. Nothing.

I tried this: with QEMU I booted the raw disk, and it worked (~as design)!

I tried to use any other (not BeOS like) OS (SuSe, Gentoo, QNX, Windows) and they worked well.

I think maybe the the notebook's (VGA)BIOS is different than the others, so maybe we need jut a little modify for the zbeos.

I'm sorry, but I cannot send any other detail, because I don't get any (no error message, just a black screen, no disk usage, no voice, nothing). If (on R5 / Dano boot) I use the original zbeos, it is booting up, all icons lights up, and the GUI... But during boot if I press any key the system halted.

I think it is not (only) a Haiku error, because I've got this in other BeOS versions what have graficaly modified zbeos (like Zeta).

So; when trying to change the boot screen (other than the BIOS screen), or hit any key, than only the reset helps. And on Haiku before the boot logo I've got only a blinking cursor in the top-left corner on the screen.

Thanks!

Róbert

comment:3 by mmlr, 11 years ago

I don't quite understand yet what your configuration is when you attempt that boot. What I gather is that you have a partitions like that:

1: Windows XP 2: BeOS R5 Pro 3: Haiku

Now what boot manager are you using to choose between them? Have you added the Haiku to that boot manager? How did you make the Haiku partition bootable?

When you say you tried booting the raw disk with QEMU you mean that you did like "qemu -snapshot /dev/disk/ide/ata/0/master/0/raw" and it worked?

comment:4 by axeld, 11 years ago

You could also try to press the space bar directly after having chosen to boot Haiku, then you enter the boot loader's menu. There you can select a different resolution, and see if that helps.

What kind of graphics chipset does that laptop have?

comment:5 by dancso.robert, 11 years ago

Hello!

I've got this laptop: http://www.gigabyte.com.tw/Products/Notebook/Products_Spec.aspx?ProductID=2043

I cannot enter the boot menu. if I press any key the system freeze up, so I cannot change the video mode during boot. And if I use the vesa file in the settings/kernel/drivers folder (I tried it on R5 and Zeta) I've got the same problem (in BeOS with the original zbeos: whent the 4th boot icon lights up it want to change the resolution (based on the vesa-file); and everything stops. it cannot change the resolution or colorspace). So I'm sure it is a vesa/bios problem, and I think the problem is in the zbeos file. Because if I use only the zbeos to boot (no OS) the problem is still exists. And this is the biggest problem, because I cannot try Haiku on my laptop, because the boot process stops after I hit enter in the bootmenu and before the boot logo shows up. But if I boot up the QEMU with /dev/disk/ide/ata/2/master/0/raw everything is ok. Haiku boots up fine. Finaly I've downloded the latest image-file from the site, and I will try that, and I want to make a video about the problem, maybe that will help a bit.

Thank you for your help!

Róbert

comment:6 by dancso.robert, 11 years ago

I tried the latest Haiku-image, and this is strange: on my Desktop PC it is working on QEMU (under Dano) and native too (on a 4GB partition). I boot it up with the BeOS Boot Manager.

But in my laptop: when I hit enter in the BeOS Boot Manager on Haiku the laptop reboots. Have no idea. :(

I did the same on my PC and laptop. What did I do (I had R5, Dano and XP on the machine):

  1. Initialize the R5 partition to BFS: /Haiku
  1. mkdir /haiku
  1. mount haiku.img /haiku
  1. cd /haiku
  1. cp -a * /Haiku
  1. bootman
  1. reboot >>> PC: working; laptop: reboot; qemu: stops at "Loading Haiku..."
  1. tried: makebootable /Haiku
  1. reboot >>> laptop: reboot; qemu: stops at "Loading Haiku..."


How I used qemu:

PC:

qemu haiku.img > OK

qemu /dev/disk/ide/ata/2/master/0/raw > OK

Laptop:

qemu /dev/disk/ide/ata/0/master/0/raw > not OK

It's strange.

comment:7 by mmlr, 11 years ago

Replying to dancso.robert:

  1. cp -a * /Haiku

I guess you meant "cp -R", right? I gather you are doing that from Dano though. Note that "cp" under BeOS will not copy attributes. This is required to boot Haiku though. It shouldn't fail as early, but it would fail later on or some parts of the system will not work as expected. Please either use the Tracker to copy the files over by drag&drop or use "copyattr -d -r * /Haiku" as a command instead.

Laptop:
qemu /dev/disk/ide/ata/0/master/0/raw > not OK

If that stalls at "Loading Haiku..." that would indicate that the partition boot record wasn't accessible or could not be executed by the BeOS boot manager. I remember that it has problems with some situations where the partition would start somewhere it couldn't access. Where does that partition start on disk, i.e. what offset does it have?

comment:8 by dancso.robert, 11 years ago

I did not re-partition my disk. On my first partition there was R5 on my PC and laptop too. I used that, so that worked. No on my PC on that Partition Haiku works, but on the laptop not.
I use the cp (cp -a = cp -dpR) because (I have no idea what can the problem be) often I want to copy a lot of file from an image to the disk (or back) the tracker freeze up before it's finished the copying. Tomorrow I will try with the d&d (or copyattr).

comment:9 by scottmc, 8 years ago

Can you recheck this with a recent Haiku build? It may have been fixed recently.

comment:10 by scottmc, 8 years ago

Blocking: 7665 added

comment:11 by tqh, 7 years ago

Resolution: invalid
Status: newclosed

This bug is four years old and without much usable info. Closing.

comment:12 by waddlesplash, 14 months ago

Blocking: 7665 removed
Note: See TracTickets for help on using tickets.