Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#2602 closed bug (duplicate)

Dell D620 cannot boot from USB key, Finding best mode failed: vm_soft_fault

Reported by: Manette Owned by: axeld
Priority: normal Milestone: R1
Component: Drivers/Graphics/intel_extreme Version: R1/pre-alpha1
Keywords: Cc: dev.haiku-os.org.manette@…
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

After my questions in ticket #2587 I was successfully booting Haiku rev 26922 from an US key on Fujitsu S7020. On my Dell D620 I still get some problems: I'm getting into gdb. intel_extreme seems to load, then try intel_get_mode_info() which leads to :

intel_get_mode_info()
Finding best mode failedFinding best mode failedvm_soft_fault: va 0x0 not covered by area in address space
vm_page_fault: vm_soft_fault returned error 'Bad address' on fault at 0x0, ip 0x29ddb1, write 0, user 1, thread 0x3e
vm_page_fault: thread "picasso" (62) in team "app_server" (62) tried to read address 0x0, ip 0x29ddb1 ("app_server_seg0ro" +0x9ddb1)

I'll attach the serial debug output (DELL-D620-Cannot-Boot-from-USB-Key-Manette-080811.txt).

I don't think there is a problem with that but the USB key I'm using declares itself as two devices: a CD drive and a USB key. The CD drive uses a part of the 1 GB for a promotional software which launch automatically when inserted in windows machines...

Don't hesitate to contact me if I can help or take measurements for you, problem seems 100% reproducible.

Attachments (1)

DELL-D620-Cannot-Boot-from-USB-Key-Manette-080811.txt (63.6 KB) - added by Manette 11 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 11 years ago by Manette

Cc: dev.haiku-os.org.manette@… added

comment:2 Changed 11 years ago by Manette

Cc: dev.haiku-os.org.manette@… removed

comment:3 Changed 11 years ago by Manette

Cc: dev.haiku-os.org.manette@… added

comment:4 Changed 11 years ago by mmlr

Resolution: duplicate
Status: newclosed

That's a duplicate of #2350. It's a more or less known problem with the intel driver / app_server disagreeing on the actual video mode used, causing the app_server to write outside of the framebuffer.

comment:5 Changed 11 years ago by mmlr

I've described a workaround in the comments to bug #2350 for the meantime. This only happens when there is no screen settings yet.

comment:6 Changed 11 years ago by axeld

Since you can reproduce it so nicely Michael, how about investigating it a bit? :-) I've looked at the app_server code, but I couldn't see anything that would cause this.

Note: See TracTickets for help on using tickets.