Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#261 closed bug (fixed)

BTextControl repainting

Reported by: diver Owned by: jackburton
Priority: normal Milestone: R1
Component: - General Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

BTextControl is somewhat buggy repainting on resize. To reproduce this, one should load haiku in vmware, open FileTypes -> Application -> Be Application and start to resize a window several times until you'll see erasing of text in BTextControl and gry color inside them. Tested with rev16575 under vmware.

Change History (8)

comment:1 Changed 13 years ago by jackburton

Happens because the BTextControl's view color (gray) is painted by the app server, and right after that, we fill part of the control with white. We should find a better way to do that.

comment:2 Changed 13 years ago by jackburton

Owner: changed from bpmagic@… to jackburton

comment:3 Changed 13 years ago by jackburton

Status: assignednew

comment:4 Changed 13 years ago by jackburton

Status: newassigned

comment:5 Changed 13 years ago by jackburton

Status: newassigned

comment:6 Changed 13 years ago by jackburton

Status: assignedclosed

comment:7 Changed 13 years ago by jackburton

Resolution: fixed

comment:8 Changed 13 years ago by jackburton

Fixed too in some of my recent BTextView commits.

Note: See TracTickets for help on using tickets.