Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#260 closed bug (fixed)

Plain font and Tab size

Reported by: diver Owned by: axeld
Priority: normal Milestone: R1
Component: - General Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Chahging plaint font size to anything more than 12pt also increase window tab size.

Attachments (1)

tab.PNG (13.9 KB) - added by diver 13 years ago.
tab size shot

Download all attachments as: .zip

Change History (23)

comment:1 Changed 13 years ago by diver

Summary: Plaint font and Tab sizePlain font and Tab size

comment:2 Changed 13 years ago by axeld

Owner: changed from bpmagic@… to axeld

comment:3 Changed 13 years ago by axeld

I can't reproduce this. Can you still do it? And if so, how?

comment:4 Changed 13 years ago by diver

Status: newclosed

comment:5 Changed 13 years ago by diver

Resolution: fixed

comment:6 Changed 13 years ago by diver

Can't reproduce it anymore too. Closing bug.

comment:7 Changed 13 years ago by diver

Resolution: fixed

comment:8 Changed 13 years ago by diver

Status: closedreopened

comment:9 Changed 13 years ago by diver

Happens again, bug is still tere. Reopening.

comment:10 Changed 13 years ago by axeld

Okay, how do you reproduce it? Because I can't. What fonts, what exactly do you do, is it always reproducible... I NEED ALL THE INFO :-)

comment:11 Changed 13 years ago by diver

(In reply to comment #4)

Okay, how do you reproduce it? Because I can't. What fonts, what exactly do you do, is it always reproducible... I NEED ALL THE INFO :-)

Ok, this is how i reproduce it, step by step: *1. Boot into Haiku. *2. In Terminal type Fonts. *3. Set Plain font and Bold Font size to 18pt. *4. Close Fonts. *5. Using Vulkan Death Grip kill tracker in deskbar. *6. BeMenu->Preferences(Applications) to start tracker.

I tested this in vmware and in native install and in both cases i had this bug. Hope this would help.

Changed 13 years ago by diver

Attachment: tab.PNG added

tab size shot

comment:12 Changed 13 years ago by axeld

It would have been nice if you had told that before: 1) the *plain* font should have nothing to do with the tab size 2) the *bold* font, however, *is* used for the tab size - and it's actually intended to be like this (same as in BeOS).

The only thing that doesn't happen right now is that all tabs are updated when you change the font or font size. Are there any other complaints about this? If not, I'd be for closing this bug :)

comment:13 Changed 13 years ago by diver

(In reply to comment #7)

It would have been nice if you had told that before:

Oh well, sorry :-)

1) the *plain* font should have nothing to do with the tab size 2) the *bold* font, however, *is* used for the tab size - and it's actually intended to be like this (same as in BeOS).

I didn't know that it was intended to be so, never seen this in BeOS.

The only thing that doesn't happen right now is that all tabs are updated when you change the font or font size. Are there any other complaints about this? If not, I'd be for closing this

bug :) Nope, no more complaints, closing bug :)

comment:14 Changed 13 years ago by diver

Resolution: invalid

comment:15 Changed 13 years ago by diver

Status: reopenedclosed

comment:16 Changed 13 years ago by diver

Resolution: invalid

comment:17 Changed 13 years ago by diver

Status: closedreopened

comment:18 Changed 13 years ago by diver

(In reply to comment #7)

1) the *plain* font should have nothing to do with the tab size

Ok, it seems that this bug wasn't wrong. Try to set plain font soze to 18 and then start Cortex. You should see modal window tab size will change. Reopening bug.

comment:19 Changed 13 years ago by axeld

You mean floating windows, not modal ones, and yes they are supposed to use the plain font - just like normal windows use the bold font :-) Sorry, I'm afraid this one will stay closed now... pleassssssse :-))

comment:20 Changed 13 years ago by axeld

Status: reopenedclosed

comment:21 Changed 13 years ago by axeld

Resolution: fixed

comment:22 Changed 13 years ago by diver

(In reply to comment #10)

You mean floating windows, not modal ones, and yes they are supposed to use

the

plain font - just like normal windows use the bold font :-) Sorry, I'm afraid this one will stay closed now... pleassssssse :-))

Oh, forgive me then for bothering you with this *bug* 3 times. :-)

Note: See TracTickets for help on using tickets.