Opened 11 years ago

Closed 11 years ago

#2612 closed bug (fixed)

'Save as' sometimes behaves unexpected

Reported by: andreasf Owned by: korli
Priority: normal Milestone: R1/alpha1
Component: Applications/StyledEdit Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

At hrev26941 The "Save as" menu items of StyledEdit and Pe do not work - the title bar displays the new file name but neither Tracker nor ls show the new file (i.e., it does not exist). If created via touch they are there right away and can be opened, modified and saved in both apps.

I assume this bug is two-part - a) both applications do not recognize the error while saving (déjà-vu... #2148), and b) the fault itself.

Change History (5)

comment:1 by axeld, 11 years ago

Component: - GeneralApplications/StyledEdit
Milestone: R1R1/alpha1
Owner: changed from axeld to korli

As far as Pe is concerned, it doesn't like to save an unchanged file, and it doesn't do so even in the "Save As" case; if you have any pending changes, "Save As" should work just fine.

I don't know what's the issue is in StyledEdit, but maybe it's something similar. In any case, Pe bugs should be reported at the proper place: http://developer.berlios.de/bugs/?group_id=5154

comment:2 by andreasf, 11 years ago

At hrev26991 I have not yet encountered this in StyledEdit again (without pending changes).

comment:3 by korli, 11 years ago

Can't reproduce here also. Was this on real hardware ?

in reply to:  3 comment:4 by andreasf, 11 years ago

Summary: 'Save as' does not work'Save as' sometimes behaves unexpected

Yes, it was.

The earlier problem I referred to (#2148) was that due to a BFS issue the volume became read-only, but StyledEdit did not complain when trying to save on it, as described above. (At that time, touch etc. didn't work either.)

Not sure if the problem is in StyledEdit itself or in libbe/whatever, but as an observation, in some corner cases the app behaves unexpected...

comment:5 by julun, 11 years ago

Resolution: fixed
Status: newclosed

fixed in hrev27225

Note: See TracTickets for help on using tickets.