Opened 11 years ago

Closed 10 years ago

Last modified 9 years ago

#2619 closed bug (invalid)

SOB17 is not work

Reported by: Hubert Owned by: axeld
Priority: normal Milestone: R1
Component: Applications Version: R1/pre-alpha1
Keywords: Cc: umccullough@…
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

SB17 is doesn't run from certain time, despite, that it run on Haiku image from February / March

Attachments (3)

screen1.png (58.1 KB) - added by Hubert 11 years ago.
Haiku_r29071_sb17.png (258.6 KB) - added by umccullough 10 years ago.
sb17 running on Haiku hrev29071
s4 (444.2 KB) - added by Hubert 10 years ago.

Download all attachments as: .zip

Change History (17)

Changed 11 years ago by Hubert

Attachment: screen1.png added

comment:1 Changed 11 years ago by Hubert

Ah, this is rev. 26999 and many earliest from last three months

comment:2 Changed 11 years ago by axeld

Sorry, but what is "SB17", and where can I get an Haiku version of it?

comment:3 Changed 11 years ago by Hubert

Seventeen Or Bust http://www.seventeenorbust.com/download/ version for R5

comment:4 Changed 11 years ago by umccullough

Last time I ran SB17 on Haiku was over 2 years ago on a PIII and it ran fine (albeit slower than expected).

http://flickr.com/photos/umccullough/130597452/sizes/o/

and

http://flickr.com/photos/umccullough/130597453/sizes/o/

Unfortunately SB17 is closed source and the version available for BeOS is actually older and doesn't support some newer processors properly. Newer versions required proper pthread support, and so they had dropped the BeOS port entirely.

I recently tried to establish interest in an updated Haiku port, but their developers are pretty busy and not terribly interested it seems:

http://www.free-dc.org/forum/showthread.php?t=13777

I will test it on a P4 2.8ghz here shortly and report my findings as well.

comment:5 Changed 10 years ago by umccullough

Cc: umccullough@… added

comment:6 Changed 10 years ago by umccullough

It seems to be working for me on hrev29071.

I had to edit my sclient.conf and set the username and team before it would work properly though.

then I ran:

$ sb ./sclient.conf

See attached screenshot :)

Changed 10 years ago by umccullough

Attachment: Haiku_r29071_sb17.png added

sb17 running on Haiku hrev29071

comment:7 Changed 10 years ago by umccullough

Now that I think about it - I believe that version of sb17 crashes on newer processors - apparently the 2.2.0 version of sb17 had some bugs that crashed on newer amd64 processors, etc, which were fixed in 2.5.0 - but there was never a 2.5.0 release for beos :( What processor are you using?

Also 2.5.0 had some performance enhancements that would have been nice...

As I said, I've been lobbying for an updated version for quite a while now - but nobody has seriously responded.

comment:8 Changed 10 years ago by Hubert

listdev: http://dev.haiku-os.org/attachment/ticket/3260/listdev-mypc.txt

Sic, I have Athlon64 X2 4600 processor. I think, when we have fresh OGR 25 client we don't watch mercy of SOB 17 team :P :D That OGR-26 used recently started SSE... ;)

comment:9 Changed 10 years ago by umccullough

I can try to test on an athlon x2 soon to make sure, but I suspect the 2.2.0 sb17 client is simply busted on newer processors and that it is not Haiku's fault.

I think we can probably close this as invalid for now.

Perhaps if/when the sb17 project devs choose to update the client to support Haiku, we can re-evaluate this.

comment:10 Changed 10 years ago by umccullough

Tested this on my core 2 duo and it's working great there as well.

I think we can probably close this as invalid now - it's not likely a Haiku issue at all.

comment:11 Changed 10 years ago by axeld

Resolution: invalid
Status: newclosed

Thanks for your investigation! And good night ;-)

comment:12 Changed 10 years ago by Hubert

Interesting. I run SB17 today in Haiku rev 29079 GCC4 (hybrid) this work great too.

Changed 10 years ago by Hubert

Attachment: s4 added

comment:13 Changed 9 years ago by mmadia

Platform: x64x86-64

comment:14 Changed 9 years ago by umccullough

Platform: x86-64x86

Hmm, this bug should not have been 64bit related in the first place

Note: See TracTickets for help on using tickets.