Opened 11 years ago

Closed 10 years ago

#2618 closed bug (fixed)

bfs: *** invalid run(0,0,0)

Reported by: emitrax Owned by: axeld
Priority: critical Milestone: R1/alpha1
Component: File Systems/BFS Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Last message repeated 2 times.
bfs: Insert:1307: Name in use
bfs: Insert:1307: Name in use
Last message repeated 3 times.
bfs: Insert:1307: Name in use
bfs: we have to panic... switch to read-only mode!
bfs: *** invalid run(0,0,0)
bfs: bfs_open:1131: Read-only file system
Last message repeated 19 times.

I don't really know how to reproduce it. I was downloading an iso with firefox while using the system.

Change History (5)

comment:1 Changed 11 years ago by emitrax

I actually managed to reproduced it three times while downloading an iso, and selecting Open with Tracker instead of saving it on disk, but I don't think that's relevant anyway.

comment:2 Changed 11 years ago by axeld

Component: - GeneralFile Systems/BFS
Milestone: R1R1/alpha1
Priority: normalcritical

comment:3 Changed 11 years ago by mmlr

I've actually seen that on my laptop as well. I investigated it a bit without result at first but then dropped it because I couldn't reproduce it on another system (I assumed the filesystem on the laptop was just a bit corrupted). If you can reproduce it like that, you should also be able to reproduce it by generating a large file through dd. It did that for me with dd if=/dev/zero of=/the/file bs=2M always around 3.8GB written.

comment:4 in reply to:  3 Changed 11 years ago by emitrax

Replying to mmlr:

I've actually seen that on my laptop as well. I investigated it a bit without result at first but then dropped it because I couldn't reproduce it on another system (I assumed the filesystem on the laptop was just a bit corrupted). If you can reproduce it like that, you should also be able to reproduce it by generating a large file through dd. It did that for me with dd if=/dev/zero of=/the/file bs=2M always around 3.8GB written.

That actually produced bug #2644, which is easy to reproduce over here.

comment:5 Changed 10 years ago by axeld

Resolution: fixed
Status: newclosed

Since I never saw this one, but just fixed a bug in the block cache that could have produced this problem in hrev28514, I'm closing this one - please reopen if it still happens for you with a newly initialized partition (or at least checked with "checkfs").

Note: See TracTickets for help on using tickets.