Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#2645 closed bug (duplicate)

Play any wav sound with Preferences, Sounds and system freezes

Reported by: cebif Owned by: marcusoverhagen
Priority: normal Milestone: R1
Component: Preferences/Sounds Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: #1708 Blocking:
Has a Patch: no Platform: All

Description

I copied some wav sounds into /boot/beos/etc/sounds and playing any one of them with the Sounds application causes my system to freeze. If I play those same sounds using MediaPlayer there is no freeze. I was testing with hrev27011 on real hardware. The steps to reproduce: 1 put some wav type sound files in the /boot/beos/etc/sounds folder. 2 Open Preferences, Sounds. 3 Select any one of these wav sounds with the Sounds app 4 Click play button The result is the system begins to freeze. It is still possible to move the mouse pointer but cannot use it to activate anything by clicking. The sound plays right to the end properly but then the freeze happens. I also got a stack trace after pressing F12. I will upload that soon.

Attachments (1)

Sounds Crash Backtrace.jpg (148.4 KB ) - added by cebif 11 years ago.

Download all attachments as: .zip

Change History (4)

by cebif, 11 years ago

Attachment: Sounds Crash Backtrace.jpg added

comment:1 by mmlr, 11 years ago

Blocked By: 1708 added
Resolution: duplicate
Status: newclosed

Duplicate of #1708.

in reply to:  1 comment:2 by cebif, 11 years ago

Replying to mmlr:

Duplicate of #1708.

With bug #1708 aiff type sounds are been used. Preferences, Sounds was able to play wav typs before but not when I tested with hrev20711. The bug is different in this respect unless wav files were also tested in #1708.

comment:3 by cebif, 11 years ago

Summary: Play any sound with Preferences, Sounds and system freezesPlay any wav sound with Preferences, Sounds and system freezes
Note: See TracTickets for help on using tickets.