Opened 11 years ago

Closed 10 years ago

#2658 closed bug (fixed)

Deskbar floating where it should after resolution change

Reported by: scottmc Owned by: axeld
Priority: normal Milestone: R1
Component: Kits/Interface Kit Version: R1/pre-alpha1
Keywords: Cc: adek336@…
Blocked By: Blocking: #4295
Has a Patch: no Platform: All

Description

This happened with hrev26168. I changed the screen resolution from 1024x768 to 1280x800 and the deskbar stay where it was, instead of moving to the upper right corner like usual. I can move it there manually and it then stays.

Attachments (1)

screen2.png (103.5 KB) - added by scottmc 11 years ago.
misplaced deskbar

Download all attachments as: .zip

Change History (11)

Changed 11 years ago by scottmc

Attachment: screen2.png added

misplaced deskbar

comment:1 Changed 11 years ago by scottmc

strange, saw it happen twice with fresh installs of hrev26168, but not now on hrev26178. guess this can be closed.

comment:2 Changed 11 years ago by scottmc

This bug is still there. I compiled an SDL demo program and when I run it, it changes the screen resolution ( 800x600 i think) and when I press ESC to exit that program the screen resolution switches back to 1280x800 and leaves the deskbar in about the middle top of the screen.

comment:3 Changed 11 years ago by Adek336

When I switch to a lower resolution, the deskbar disappears.

comment:4 Changed 11 years ago by Adek336

But not always.

comment:5 Changed 10 years ago by Adek336

Cc: adek336@… added

comment:6 Changed 10 years ago by axeld

Component: - GeneralServers/app_server
Resolution: fixed
Status: newclosed

Fixed in hrev28908.

comment:7 Changed 10 years ago by Adek336

Resolution: fixed
Status: closedreopened

Well, it looks like it's still bugging us in hrev28945.

comment:8 Changed 10 years ago by jackburton

Can you check with hrev32420 or later ?

comment:9 Changed 10 years ago by axeld

Blocking: 4295 added

(In #4295) It's indeed a duplicate, it just happens reproducible now since the app_server works correctly.

comment:10 Changed 10 years ago by axeld

Component: Servers/app_serverKits/Interface Kit
Resolution: fixed
Status: reopenedclosed

Fixed in hrev32557.

Note: See TracTickets for help on using tickets.