Opened 10 years ago

Closed 10 years ago

#4295 closed bug (duplicate)

Deskbar is draw at the wrong position when using BWindowScreen.

Reported by: bga Owned by: axeld
Priority: normal Milestone: R1
Component: Kits/Interface Kit Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: #2658 Blocking:
Has a Patch: no Platform: All

Description

Start a BWindowScreen program, like ParticlesII. While it is running, switch workspaces. Deskbar is draw in the wrong position (aparently in the same position, in absolute pixels, that it would be draw in the (now smaller) BWindowScreen covered workspace.

This is arecent regression. probably related to recent changes on handling resolution changes in cases like this.

Change History (2)

comment:1 by axeld, 10 years ago

Component: Kits/Application KitKits/Interface Kit
Status: newassigned

You don't read commit messages when they get longer, do you? :-)

Anyway, I am looking into it now (as mentioned there), but I have high hopes that this is not a freshly introduced problem, but a duplicate of #2658, that just happens much more often now.

I'll leave this open for now until I'm sure.

comment:2 by axeld, 10 years ago

Blocked By: 2658 added
Resolution: duplicate
Status: assignedclosed

It's indeed a duplicate, it just happens reproducible now since the app_server works correctly.

Note: See TracTickets for help on using tickets.