Opened 11 years ago

Closed 10 years ago

#2665 closed enhancement (fixed)

Donating codes: APE reader

Reported by: shinta Owned by: dlmcpaul
Priority: normal Milestone: R1
Component: Audio & Video/Codecs Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

I donate my APE reader codec's source codes to Haiku.

This post is based on http://www.freelists.org/archives/haiku-development/06-2008/msg00049.html

Haiku: hrev26161
SHINTA (enhancement No.5)

Attachments (3)

APEReaderDonate.zip (66.0 KB) - added by shinta 11 years ago.
LibMonkeysAudioDonateRev2.zip (181.8 KB) - added by shinta 11 years ago.
APE_reader.diff (1.7 KB) - added by shinta 10 years ago.
Patch for seek

Download all attachments as: .zip

Change History (21)

Changed 11 years ago by shinta

Attachment: APEReaderDonate.zip added

Changed 11 years ago by shinta

comment:1 Changed 11 years ago by shinta

Above files are APE reader and static libs. Please build these files to Haiku.

comment:2 Changed 11 years ago by stippi

I wanted to take care of this, but still have not taken the time to do so... sorry! Anyone else, please feel free to beat me to it, otherwise I still plan on doing it.

comment:3 Changed 10 years ago by koki

Cc: koki added

Gentle reminder. :)

comment:4 Changed 10 years ago by anevilyak

Owner: changed from marcusoverhagen to dlmcpaul

Reassigning since Marcus doesn't have much time currently.

comment:5 Changed 10 years ago by koki

According to this...

https://lists.berlios.de/pipermail/haiku-commits/2009-March/015277.html

...the "APE Reader from sources donated by SHINTA" have been committed. So it looks like it's OK to close this one.

comment:6 Changed 10 years ago by dlmcpaul

Resolution: fixed
Status: newclosed

code has been committed

comment:7 Changed 10 years ago by shinta

Thank you for committing.

Changed 10 years ago by shinta

Attachment: APE_reader.diff added

Patch for seek

comment:8 Changed 10 years ago by shinta

Above patch is for seeking.

BTW, how can I jam APE reader? "jam" at APE_reader folder doesn't work. Only shown "found 10 target(s)" and APE reader isn't generated.

comment:9 Changed 10 years ago by anevilyak

That's because the APE reader is not part of HaikuImage yet. You could either add it there (to SYSTEM_ADD_ONS_MEDIA_PLUGINS) or add a command to UserBuildConfig to add it.

comment:10 Changed 10 years ago by stippi

Not quiet. :-) The problem is that APE_reader is not part of the Jamfile tree. In the parent folder, you need to add the sub-folder of APE_reader in the Jamfile there. Right now, it doesn't build for me, most likely because I don't have nasm installed (on Haiku).

comment:11 Changed 10 years ago by shinta

Yes, Assembly.nasm seems not to be compiled. But, there is a pre-compiled Assembly.o in LibMonkeysAudioDonateRev2.zip.

How about committing Assembly.o temporarily?

comment:12 Changed 10 years ago by axeld

We've done that at least at one other place (the stage 1 boot loader), but I would rather like to see that fixed, ie. have nasm as part of the build dependencies.

APE is not the only candidate that would benefit from this.

comment:13 in reply to:  11 Changed 10 years ago by dlmcpaul

Replying to shinta:

Yes, Assembly.nasm seems not to be compiled. But, there is a pre-compiled Assembly.o in LibMonkeysAudioDonateRev2.zip.

How about committing Assembly.o temporarily?

If you have nasm in your path Assembly.nasm should compile for you.

comment:14 in reply to:  12 Changed 10 years ago by dlmcpaul

Replying to axeld:

We've done that at least at one other place (the stage 1 boot loader), but I would rather like to see that fixed, ie. have nasm as part of the build dependencies.

APE is not the only candidate that would benefit from this.

Yes, avcodec has a number of asm sources I want to include.

Anyway, I hope to try and get yasm into BuildTools.

I prefer yasm over nasm.

comment:15 Changed 10 years ago by shinta

Thank you for putting ape_reader to HaikuImage.

Would you also commit above seeking patch?

comment:16 Changed 10 years ago by dlmcpaul

Resolution: fixed
Status: closedreopened

Ok will do.

I will re-open the ticket so I don't forget.

comment:17 Changed 10 years ago by luroh

Fixed in hrev30143, right? Works here in 30247 anyway.

comment:18 Changed 10 years ago by dlmcpaul

Resolution: fixed
Status: reopenedclosed

Should be all ok now

Note: See TracTickets for help on using tickets.