Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#268 closed bug (fixed)

Transparent support broken for B_CMAP8

Reported by: axeld Owned by: mmlr
Priority: normal Milestone: R1
Component: - General Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Looks like your recent BBitmap changes broke transparent handling for icons. Visible with the FileTypes application: all icons have white background, instead of shining through, as before.

Change History (6)

comment:1 Changed 13 years ago by mmlr

This is actually a BeOS misbehaviour. BeOS uses the alpha channel of B_RGB32 like the one of B_RGBA32 even though according to GraphicsDefs.h and the BeBook B_RGB32 does not include an alpha channel at all. Fixed this by handling B_RGB32 and B_RGBA32 in the same way. Will commit the change when I get home today.

comment:2 Changed 13 years ago by axeld

Even though BeOS might have this bug (dunno), I'm drawing B_CMAP8 bitmaps here, so I don't see the connection (even if this fix does the trick, at least I'm clueless) :-)

comment:3 Changed 13 years ago by mmlr

Ok, you are right, the problem was caused by converting the B_CMAP8 icon to B_RGB32 instead of B_RGBA32 before blitting it in the app_server. Changed this and will commit tonight.

comment:4 Changed 13 years ago by mmlr

Status: newclosed

comment:5 Changed 13 years ago by mmlr

Resolution: fixed

comment:6 Changed 13 years ago by mmlr

Fixed in hrev16660.

Note: See TracTickets for help on using tickets.