Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#269 closed bug (fixed)

Dragging a Tracker icon deadlocks app_server

Reported by: marcusoverhagen Owned by: mmlr
Priority: blocker Milestone: R1
Component: - General Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

When trying to drag Media preferences icon from Tracker into Terminal, app_server does deadlock. Mouse cursor, keyboard navigation and team monitor no longer work. input_server seems to be still alive, as pressing num-lock key triggers the keyboard LED.

Tested at revision 16637

Change History (9)

comment:1 Changed 13 years ago by marcusoverhagen

* Bug 270 has been marked as a duplicate of this bug. *

comment:2 Changed 13 years ago by mmlr

Drag and drop is not yet implemented correctly. I am in the process of correcting it using the new reference-only BMessage passing. Currently all kinds of deadlocks will occure with most drag&drop actions. Note that fixing this will require switching to Message4.

comment:3 Changed 13 years ago by mmlr

Status: newassigned

comment:4 Changed 13 years ago by mmlr

Status: assignednew

comment:5 Changed 13 years ago by mmlr

Owner: changed from axeld to mmlr

comment:6 Changed 13 years ago by marcusoverhagen

dependson: 271

comment:7 Changed 13 years ago by stippi

Status: newclosed

comment:8 Changed 13 years ago by stippi

Resolution: fixed

comment:9 Changed 13 years ago by stippi

Should be fixed since 16657. (just the "deadlock")

Note: See TracTickets for help on using tickets.