Opened 11 years ago

Closed 8 years ago

#2687 closed bug (fixed)

Multi-function USB card reader does not work.

Reported by: bga Owned by: mmlr
Priority: high Milestone: R1
Component: Drivers/USB Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking: #4374
Has a Patch: no Platform: All

Description (last modified by bga)

USB in general dose work on my machine. Even plugging in a pen-drive works without problems. But I have this multi-function card reader that does not work. When I connect it, I get these messages in syslog:

KERN: usb_ehci: qtd (0x04028980) error: 0x00080248
KERN: usb_ehci: qtd (0x04028b80) error: 0x00080248
KERN: usb_ehci: qtd (0x04028d80) error: 0x00080248
KERN: USB BusManager: error while setting device address

In Linux and Windows, this shows up as several different devices (one for each card it supports, like MMC, SD, Memory Stick, etc) in case that matters.

Change History (11)

comment:1 Changed 11 years ago by bga

Description: modified (diff)

comment:2 Changed 11 years ago by mmlr

Can you provide some more details on how you hook this device up? Is that after a hub for example or directly into a root port, does it work on other ports? Does the device work on another system using Haiku maybe? This is really a low-level problem, as setting the device address is the very first thing that has to be done to setup a device. It is pretty unusual that this fails, so the more details you can give about the hardware and how it is connected, the more likely I can spot a peculiarity that points in the direction of the bug. Hub chaining with mixed high/fullspeed hubs was broken for example and since it is a rather seldom configuration it was tricky to find the cause and fix it.

comment:3 Changed 11 years ago by bga

1 - As far as I know, it is directly to a root port (it is in a front panel connector in my case that is connected directly to the motherboard).

2 - I don´t know if it works on a different system running Haiku. I only have one system here. Sorry.

3 - Well, it it helps, my printer connected to the same port also has problems (99% of interrupts on vector x are unhandled) and Haiku does not even boot if the printer is on, hanging with the messa mentioned. OTOH, the pen-drive I have works ok on exactly the same port and I can even boot and run Haiku out of it.

comment:4 Changed 11 years ago by bga

And yes, both the printer and the card reader work under Linux and Windows on the same machine.

comment:5 Changed 9 years ago by mmlr

Blocking: 4374 added

(In #4374) I take it this is a duplicate of #2687.

comment:6 Changed 8 years ago by mmlr

Depending on the chipset this might be #5551. Do you have some info on that machine?

comment:7 Changed 8 years ago by stargatefan

can this be closed with ioapic routing being fixed???. I have a similar card reader and it works fine now that the ioapic is working correctly. should be in my logs from ticket 5551.I did have issues with it not working properly before ioapic and it only worked when a card was slotted during boot.

comment:8 Changed 8 years ago by scottmc

@bga can you recheck this with a fresh Haiku build?

comment:9 Changed 8 years ago by pulkomandy

How long do we wait for bga before closing this ?

comment:10 Changed 8 years ago by bga

pulkomandy: If you want my attention, the best option is to simply mail me and not assume that I am following what is happening to a bug opened 3 years ago. Also, closing a bug just because it is old usually does not make the problem go away. So either the bug is fixed and you close it, or it is not and you do not close it. There should not be an expiration date attached to a bug unless it was made obsolete by something else (which is not the case here).

mmlr: I will check and get back to you. My machine was not able to boot Haiku recently, crashing on the vesa accelerant. I will try to get it to boot and will validate if your changes fixed my problem. Thanks.

comment:11 Changed 8 years ago by bga

Resolution: fixed
Status: newclosed

Ok. Seems to be fixed. Closing this. Thanks.

Note: See TracTickets for help on using tickets.