Opened 10 years ago

Closed 9 years ago

#4374 closed bug (duplicate)

USB sometimes fail to assign an address to a device.

Reported by: bga Owned by: mmlr
Priority: high Milestone: R1
Component: Drivers/USB Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: #2687 Blocking:
Has a Patch: no Platform: All

Description

I have this USB card reader. Sometimes when I connect it to one of the several USB ports on my computer, I get this in syslog:

2009-08-29 17:08:48 KERN: usb hub 32: port 4: new device connected
2009-08-29 17:08:49 KERN: usb error ehci 6: qtd (0x041d4680) error: 0x00080248
2009-08-29 17:08:49 KERN: usb error ehci 6: qtd (0x041d4880) error: 0x00080248
2009-08-29 17:08:49 KERN: usb error ehci 6: qtd (0x041d4a80) error: 0x00080248
2009-08-29 17:08:49 KERN: usb error ehci 6: error while setting device address

And, of course, the device is not recognized.

If I remove and reinsert it (may need to do it a few times) sometimes it is picked up:

2009-08-29 17:10:13 KERN: usb hub 32: port 4: new device connected
2009-08-29 17:10:14 KERN: usb_disk: device reports a lun count of 4
2009-08-29 17:10:14 KERN: usb_disk: vendor_identification    "Generic "
2009-08-29 17:10:14 KERN: usb_disk: product_identification   "USB SD Reader   "
2009-08-29 17:10:14 KERN: usb_disk: product_revision_level   "1.00"
2009-08-29 17:10:14 KERN: usb_disk: vendor_identification    "Generic "
2009-08-29 17:10:14 KERN: usb_disk: product_identification   "USB CF Reader   "
2009-08-29 17:10:14 KERN: usb_disk: product_revision_level   "1.01"
2009-08-29 17:10:14 KERN: usb_disk: vendor_identification    "Generic "
2009-08-29 17:10:14 KERN: usb_disk: product_identification   "USB SM Reader   "
2009-08-29 17:10:14 KERN: usb_disk: product_revision_level   "1.02"
2009-08-29 17:10:14 KERN: usb_disk: vendor_identification    "Generic "
2009-08-29 17:10:14 KERN: usb_disk: product_identification   "USB MS Reader   "
2009-08-29 17:10:14 KERN: usb_disk: product_revision_level   "1.03"
2009-08-29 17:10:14 KERN: usb_disk: request_sense: key: 0x06; asc: 0x28; ascq: 0x00;

And works as expected.

Change History (1)

comment:1 Changed 9 years ago by mmlr

Blocked By: 2687 added
Resolution: duplicate
Status: newclosed

I take it this is a duplicate of #2687.

Note: See TracTickets for help on using tickets.