Opened 9 years ago

Closed 8 years ago

#2694 closed bug (fixed)

[pairs] Sometime, pairs show two times the same pair.

Reported by: oco Owned by: axeld
Priority: normal Milestone: R1
Component: Applications Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Sometime, pairs show two times the same pair as you can see on the attached image.

I am not sure if it was intended.

On the other hand, it add some complexity to the game...

Change History (3)

comment:1 Changed 9 years ago by oco

Here is the screenshot : http://olivier.coursiere.free.fr/images/TwoTimesTheSamePair.png

I can not upload it here right now because of bug 2660

comment:2 Changed 9 years ago by axeld

This probably happens because some icons are used more than once in Haiku. Since this is not really an unlikely scenario anyway, Pairs should check if it already has a certain bitmap before keeping it.

comment:3 Changed 8 years ago by axeld

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in hrev28133.

Note: See TracTickets for help on using tickets.