Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#2699 closed bug (fixed)

KDL when accessing a DVD or CD

Reported by: cebif Owned by: axeld
Priority: critical Milestone: R1/alpha1
Component: File Systems/ISO 9660 Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I mounted a DVD movie and double clicked on its icon. This resulted in KDL. I then tried right clicking. The same thing again. I tried to open it from VLC, via the file menu but KDL again. I then tried a CDR with Mandriva Linux burned on it (iso9660), KDL again. To reproduce:

  1. Mount a DVD or CD disk.
  2. Double click or right click or navigate to from VLC or MediaPlayer, to open.

The result is immediate KDL. I will upload a sc from KDL when I tried to open the DVD movie.

Attachments (1)

SC from KDL opening DVD movie.jpg (486.6 KB ) - added by cebif 11 years ago.
Stacktrace from KDL double clicking on DVD movie icon.

Download all attachments as: .zip

Change History (26)

by cebif, 11 years ago

Stacktrace from KDL double clicking on DVD movie icon.

comment:1 by cebif, 11 years ago

I was testing hrev27258.

comment:2 by emitrax, 11 years ago

Just to make sure, did you add udf to the iso? Because by default it is not in the image yet.

comment:3 by emitrax, 11 years ago

Sorry, by iso I mean tha haiku image.

in reply to:  3 comment:4 by cebif, 11 years ago

Replying to emitrax:

Sorry, by iso I mean tha haiku image.

No, I did not compile a haiku image. The crash happens with different types of file systems but I have only tested with iso9660, DVD movie and a DVD+RW I burned but not certain of its fs. Is udf in DVD movie? I will have to check what the different fs types are on the disks.

comment:5 by cebif, 11 years ago

Found the DVD+RW is burned with iso9660.

comment:6 by emitrax, 11 years ago

As far as I can tell from the bt this does not seem to be related to the FS. It seems to be a tracker problem, and IIRC I traced it once with Renè. The ASSERT that triggers the panic has been introduced by Axel in hrev27128, and it is involved for user space caller only. What I don't understand it is why the ASSERT is not trigger everytime you try to access a media, as the code path involved should be the same. Perhaps someone else can tell you (and me) more.

in reply to:  6 comment:7 by cebif, 11 years ago

Replying to emitrax:

As far as I can tell from the bt this does not seem to be related to the FS. It seems to be a tracker problem, and IIRC I traced it once with Renè. The ASSERT that triggers the panic has been introduced by Axel in hrev27128, and it is involved for user space caller only. What I don't understand it is why the ASSERT is not trigger everytime you try to access a media, as the code path involved should be the same. Perhaps someone else can tell you (and me) more.

When you say "everytime you try to access media", do you mean any CD's or other disks with video or audio? I tried to access a data CD and a data DVD and the crash happened as well. Or do you mean all types of physical removeable media?

comment:8 by cebif, 11 years ago

I have tested with a USB digital camera SD memory and a audio CDROM. I can make the crash happen when the SD memory is mounted in read/write but not read-only. I cannot make the crash happen with the audio CD. The audio CD was is off course read-only but a choice is given to mount read/write or read-only when mounting. I don't know what would happen if I selected read/write.

comment:9 by cebif, 11 years ago

I can make the crash happen for all removeable disks except audio CDROMS. With a USB SD memory card; the crash will only happen if it is mounted read/write.

comment:10 by kev, 11 years ago

I'm having this problem as well, trying to read a DVD-R that I burned in UDF102 format in Windows XP using Roxio Creator Classic. Instant KDL when I double-click the desktop icon (even though it auto-mounts fine.) This is on hrev27393.

comment:11 by kev, 11 years ago

I guess the build factory is still down...any word on how close udf is to being included by default?

comment:12 by emitrax, 11 years ago

This has nothing to do with UDF. It's more likely a tracker problem, as I sais already. Have you tried listing the content of the media from terminal?

As for udf being included to the image by default, there is bug that have to be fixed first.

comment:13 by axeld, 11 years ago

Component: System/libroot.soFile Systems/ISO 9660
Milestone: R1R1/alpha1
Priority: normalcritical
Resolution: fixed
Status: newclosed

Fixed in hrev27408.

comment:14 by cebif, 11 years ago

I am still getting the bug here, testing with hrev27407 installed on HD. Most of the stacktraces are the same except for one, when I tried to open a mounted data DVD. Can I open this again?

comment:15 by cebif, 11 years ago

Sorry I didn't notice I was testing one version behind hrev27408. It was the latest version available so I thought I had downloaded an image with the fix.

comment:16 by cebif, 11 years ago

Finally made sure to get the right image hrev27420. There are no more crashes but any CD or DVD I mount and open show as blank but they have folders and files. It doesn't matter if they have been burned or are bought disks. Is this part of the same bug or another one?

in reply to:  16 ; comment:17 by emitrax, 11 years ago

Replying to cebif:

Finally made sure to get the right image hrev27420. There are no more crashes but any CD or DVD I mount and open show as blank but they have folders and files. It doesn't matter if they have been burned or are bought disks. Is this part of the same bug or another one?

If the media are UDF formatted, that's unfortunately the expected behavior for now, since there is not udf module and they get picked by the iso9660 one.

in reply to:  17 comment:18 by cebif, 11 years ago

Replying to emitrax:

Replying to cebif:

Finally made sure to get the right image hrev27420. There are no more crashes but any CD or DVD I mount and open show as blank but they have folders and files. It doesn't matter if they have been burned or are bought disks. Is this part of the same bug or another one?

If the media are UDF formatted, that's unfortunately the expected behavior for now, since there is not udf module and they get picked by the iso9660 one.

They are not UDF formatted. They were mostly iso9660.

comment:19 by cebif, 11 years ago

The only two type CD's I can veiw the contents of is an old BeOSR4.5.2 install disk. This part of the disk is formatted in bfs. It also has another partition on it that runs from Windows for creating a HD partition to intall Beos. That CD partition, I cannot view the contents of. It is formatted in iso9660. I can also view the contents of an audio CD. It is formatted in cdda.

comment:20 by cebif, 11 years ago

Resolution: fixed
Status: closedreopened

I just tried mounting a digital camera SD memory card in read write mode and got KDL when I double clicked on its icon. I did a stacktrace and it is similar to the original stacktrace for this bug. If I open it in read only there is no crash. I think I will reopen this.

comment:21 by cebif, 11 years ago

The stacktrace for Ticket #2700 looks the same as the trace for this bug.

comment:22 by axeld, 11 years ago

Resolution: fixed
Status: reopenedclosed

An SD card has nothing to do with the ISO9660 file system, please don't just reopen tickets where you see fit.

If you have a file system different to ISO9660 (this bug), or ext3 (bug #2700), then please just open a new ticket.

in reply to:  22 comment:23 by cebif, 11 years ago

Replying to axeld:

An SD card has nothing to do with the ISO9660 file system, please don't just reopen tickets where you see fit.

If you have a file system different to ISO9660 (this bug), or ext3 (bug #2700), then please just open a new ticket.

I thought it was more or less clear this bug was not reported as just applying to iso9660. I also thought reopening a bug was allowable to non developers otherwise the radio box would not have been available to me. Just like it is not available to a non developer to delete an invalid backtrace or attachment.

comment:24 by axeld, 11 years ago

Have you read the summary or the description? It clearly mentions CDs and DVDs as well as iso9660, and nothing more. How could it be clear that this bug was about everything else?

While it's technically allowed for you to reopen bugs, it's just annoying when you do so incorrectly. When in doubt, just ask before. This was an iso9660 specific bug, and it has been fixed. This is clearly visible by the component this bug has been assigned to as well as the changeset that fixed it.

If the CD appears empty, than this is just another bug in iso9660.

If your SD card let's you drop into KDL, this is not a problem of iso9660.

in reply to:  24 comment:25 by cebif, 11 years ago

Replying to axeld:

Have you read the summary or the description? It clearly mentions CDs and DVDs as well as iso9660, and nothing more. How could it be clear that this bug was about everything else?

While it's technically allowed for you to reopen bugs, it's just annoying when you do so incorrectly. When in doubt, just ask before. This was an iso9660 specific bug, and it has been fixed. This is clearly visible by the component this bug has been assigned to as well as the changeset that fixed it.

If the CD appears empty, than this is just another bug in iso9660.

If your SD card let's you drop into KDL, this is not a problem of iso9660.

Sorry for feeling a bit hot here. I'm the one that reported this bug I should know what I stated and meant. I know I stated iso9660 as one of the file systems but I wasn't saying that it was a file system specific bug. At that point I wasn't certain. I was wanting to test more as shown in a slightly later comment to emitrax:

"Replying to emitrax:

Sorry, by iso I mean tha haiku image.

No, I did not compile a haiku image. The crash happens with different types of file systems but I have only tested with iso9660, DVD movie and a DVD+RW I burned but not certain of its fs. Is udf in DVD movie? I will have to check what the different fs types are on the disks." Although I didn't say it outright I was more under the impression it was a tracker type bug, as stated outright by emitrax. In my initial report I had the component as: libroot.so. I'm not saying you should have left it at that (I know you're knowledge is greater) but that shows I wasn't saying the component was iso9660. Yes I probably should have asked again. I did ask once but this whole comment (that I asked it in can be looked at as invalid because I had the wrong image). Sorry for not doing that. I was feeling frustrated because one other bug I reported before this was almost immediately marked as copy (not by you) when there was crucial difference. I asked to reopen it and the reason why but have not had a reply in weeks. Any way that particular bug is really fixed now. Is my bug or any one elses vanity.

Note: See TracTickets for help on using tickets.