Opened 11 years ago

Closed 4 years ago

#2703 closed bug (fixed)

Quake2 memory allocation issues

Reported by: digitalteufel Owned by: axeld
Priority: normal Milestone: R1
Component: - General Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

The vast majority of Quake2 crashes seem to take place during various memory allocations and they all seem to involve the failure of an assertion in BPrivate::superblock::isValid(). The crashing seems to be random so sometimes it'll get far enough to actually load a map and allow me to play.

The backtraces below only show the failure of the "_numBlocks > 0" assertion but the other two in isValid() fail on occasion as well.

Attachments (3)

quake2crash-1.png (324.1 KB) - added by digitalteufel 11 years ago.
quake2crash-2.png (314.9 KB) - added by digitalteufel 11 years ago.
quake2crash-3.png (300.9 KB) - added by digitalteufel 11 years ago.

Download all attachments as: .zip

Change History (5)

Changed 11 years ago by digitalteufel

Attachment: quake2crash-1.png added

Changed 11 years ago by digitalteufel

Attachment: quake2crash-2.png added

Changed 11 years ago by digitalteufel

Attachment: quake2crash-3.png added

comment:1 Changed 5 years ago by pulkomandy

I can't reproduce this. There seem to be other issues with running Quake 2, however:

  • Corrupted audio
  • Game freezes as soon as I try to start a game.

comment:2 Changed 4 years ago by waddlesplash

Resolution: fixed
Status: newclosed

I think audio has been fixed, IIRC. The game freezing is a totally separate issue.

Note: See TracTickets for help on using tickets.