Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#2705 closed bug (invalid)

safemode unable to delete files

Reported by: Adek336 Owned by: axeld
Priority: normal Milestone: R1
Component: - General Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

There is no apparent way to shutdown the computer from the safemode (typing exit just disables the console). So the file is deleted in system buffers but those are never written back to the disk. Expected behaviour: typing "exit" in the console does a proper shutdown.

Change History (6)

comment:1 by anevilyak, 11 years ago

The shutdown command is also available from the console last I checked.

comment:2 by anevilyak, 11 years ago

This bug description is inaccurate anyways, since the files will get deleted once the page writer gets to them, which most likely will be a few seconds. Otherwise it can be forced immediately via the 'sync' command.

comment:3 by bonefish, 11 years ago

Resolution: invalid
Status: newclosed

comment:4 by Adek336, 11 years ago

I'm still in favor of having the "exit" command flush the buffers; it is so intuitive to end the session with an "exit" and many users will not think about waiting a few seconds before rebooting or issueing a "sync" and will be surprised that the changes they made to the disk aren't there.

comment:5 by mmlr, 11 years ago

No, you misunderstood what was said. There is the normal "shutdown" command that functions the same as under a normally loaded Haiku and should be used to shut down Haiku in safemode. The exit command is a shell built-in to close the shell process, it's not a system tool. The shell that you see there is a normal bash, not a Haiku specific shell, so the built-ins work as they usually do in bash.

What seems to be a bug though is that the shell is not actually restarted when the shell exits. It states that the shell is restarted but doesn't. Please open a new ticket for that.

in reply to:  5 comment:6 by bonefish, 11 years ago

Replying to mmlr:

What seems to be a bug though is that the shell is not actually restarted when the shell exits. It states that the shell is restarted but doesn't. Please open a new ticket for that.

No, please don't. The "safe mode" is going to go away anyway.

Note: See TracTickets for help on using tickets.