Opened 11 years ago

Closed 5 years ago

#2718 closed bug (fixed)

KDL when iterating over files in the filesystem (DiskUsage).

Reported by: bga Owned by: axeld
Priority: critical Milestone: R1
Component: System/Kernel Version: R1/pre-alpha1
Keywords: vm Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I can reproduce this on my installation 100% of the time. If I run DiskUsage in my boot disk, it will take a lot of time to process all files (I have literally millions of files in this partition) and, at some point during this time, it ends up trowing the system to KDL with a panic:

PANIC: ASSERT FAILED (src/system/kernel/vm/vm_page.cpp:1765): sReservedPages >= count

The machine has plenty of memory (3 Gb available to the OS out of 4 Gb total. 1 Gb is stolen by two video cards with 512 Mb of memory each).

See attached screenshot for full stack trace.

Attachments (2)

kdl.jpg (101.1 KB) - added by bga 11 years ago.
KDL stack trace
kdl_backtrace.jpg (319.7 KB) - added by oco 10 years ago.

Download all attachments as: .zip

Change History (6)

Changed 11 years ago by bga

Attachment: kdl.jpg added

KDL stack trace

comment:1 Changed 10 years ago by oco

I think i have another test case that lead to the same error : i run a query to search all files of type "audio". I have many partitions with lots of files (two haiku source tree at least). It seems there is a leak somewhere while running this kind of queries, even if no files are found. After a while (about one hour), i have the above error (see attached back trace). My machine have 4 Gb of memory (well 3 Gb). The problem exist with or without a swap file. I was not able to reproduce it on an older one with only 512 Mo of RAM.

Changed 10 years ago by oco

Attachment: kdl_backtrace.jpg added

comment:2 Changed 10 years ago by bga

I never got that anymore (bur I never tried DiskUsage again anyway). Interesting enough, my machine also has 4 Gb of memory (3 because of my video cards). I wonder if this is not an edge case not being correctly handled in the VM.

comment:3 Changed 7 years ago by bonefish

Keywords: vm added

comment:4 Changed 5 years ago by bonefish

Resolution: fixed
Status: newclosed

Given that major work has been done on the VM since the bug has been reported (particularly in 2010) and no more recent reports of the issue exist, so I'm closing the ticket. Please reopen, if encountered again.

Note: See TracTickets for help on using tickets.