Opened 11 years ago

Closed 8 years ago

Last modified 8 years ago

#2739 closed bug (invalid)

KDL at boot with SBLive

Reported by: biffuz Owned by: mmu_man
Priority: normal Milestone: R1
Component: Drivers/Audio/OpenSound Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Just updated Haiku to hrev25795 (don't remember the previous one), built myself with buildtools, and now it crashes at boot. It seems it has something to do with OSS and the SBLive driver.

Attachments (1)

17092008.jpg (339.5 KB) - added by biffuz 11 years ago.
SC taken with phone (sorry it's the best I can do atm)

Download all attachments as: .zip

Change History (16)

Changed 11 years ago by biffuz

Attachment: 17092008.jpg added

SC taken with phone (sorry it's the best I can do atm)

comment:1 Changed 11 years ago by umccullough

You should *not* be using OSS on hardware that Haiku already has a supported driver for.

The current OSS port is not "intelligent" enough to disable itself when Haiku has a built-in driver, and thus it will likely cause conflicts when both drivers try to access the same hardware simultaneously.

Thus, OSS should only be installed and used when absolutely necessary in the event that no native driver exists for your hardware.

comment:2 in reply to:  1 Changed 11 years ago by biffuz

Well, but why this happens only now? It didn't, and I did not change the build config since previous build. Or maybe I should go with a clean install and try again?

comment:3 Changed 11 years ago by umccullough

Maybe you just got lucky?

Simply put, there's currently no protection in place to prevent OSS from colliding with the built-in emuxki driver - and thus you shouldn't expect the system to be stable when using both. This has already been explained in the past by mmu_man, and he knows there needs to be a solution in the future.

comment:4 Changed 11 years ago by biffuz

Tried with a fresh install, no luck. The crash is 100% reproducible. Probably something was wrong with the older one, who knows.

comment:5 Changed 11 years ago by umccullough

Component: - GeneralDrivers/Audio
Owner: changed from axeld to korli

To verify if it's actually a problem with the built-in emuxki driver in combination with OSS, you could always boot to safe mode console and remove that driver from the system manually.

It's hard to see in the picture, but it looks like the panic is that it has acquired a lock with interrupts disabled.

It might just be a bug in OSS or something?

comment:6 Changed 11 years ago by biffuz

I tried to delete emuxki driver and OSS still crashes!

comment:7 Changed 11 years ago by korli

Owner: changed from korli to mmu_man

comment:8 Changed 11 years ago by mmu_man

Status: newassigned

Could you try using this newer version ? It should fix several bugs including a nasty too small malloc in my code. http://revolf.free.fr/beos/oss-beos-v4.1test-bin.zip

comment:9 in reply to:  8 Changed 11 years ago by biffuz

Replying to mmu_man:

Could you try using this newer version ? It should fix several bugs including a nasty too small malloc in my code. http://revolf.free.fr/beos/oss-beos-v4.1test-bin.zip

Nothing changed, exactly the same crash.

comment:10 Changed 11 years ago by mmu_man

You really sure you removed the native driver ?

comment:11 in reply to:  10 Changed 10 years ago by biffuz

Replying to mmu_man:

You really sure you removed the native driver ?

Yes :-) I also tried to delete all audio drivers (just in case), but no help.

comment:12 Changed 10 years ago by peat

I also get a kdl when oss is installed. (sblive 5.1 emuxki) At boot it shows:

PANIC: aquire_spinlock: attempt to aquire lock 0x81ecba08 with interrupts enabled

Without oss drivers it loads fine and sound works.

comment:13 in reply to:  12 Changed 10 years ago by anevilyak

Replying to peat:

I also get a kdl when oss is installed. (sblive 5.1 emuxki) At boot it shows:

PANIC: aquire_spinlock: attempt to aquire lock 0x81ecba08 with interrupts enabled

That would be OpenSound conflicting with the native emuxki driver.

comment:14 Changed 8 years ago by scottmc

Resolution: invalid
Status: in-progressclosed

Try retesting Haiku with a recent build and if it still isn't working for you please reopen this ticket, and include details of what you tried including Haiku revision number.

comment:15 Changed 8 years ago by diver

Component: Drivers/AudioDrivers/Audio/OpenSound
Note: See TracTickets for help on using tickets.