Opened 11 years ago

Closed 11 years ago

#2822 closed bug (duplicate)

mblen function always returns 0

Reported by: augiedoggie Owned by: axeld
Priority: normal Milestone: R1
Component: System/libroot.so Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

The mblen function is supposed to return the number of bytes for a specific character but it is always returning 0. I am attaching a simple program that runs fine on linux and OSX(i.e. it returns 1). You sould be able to compile it and then run:

./mbtest a

or

./mbtest 1

or

./mbtest whatever

Unfortunately I don't know enough about setting locales and character conversion to provide a better report.

Attachments (1)

mbtest.c (188 bytes) - added by augiedoggie 11 years ago.

Download all attachments as: .zip

Change History (2)

Changed 11 years ago by augiedoggie

Attachment: mbtest.c added

comment:1 Changed 11 years ago by anevilyak

Resolution: duplicate
Status: newclosed

Duplicate of ticket #1881 and #1855, none of these functions will work correctly until glibc's wide character support is correctly handled.

Note: See TracTickets for help on using tickets.