Opened 11 years ago

Closed 8 years ago

#2867 closed bug (fixed)

Keyboard troubles on HP Compaq nx9420

Reported by: cedric.be Owned by: siarzhuk
Priority: normal Milestone: R1
Component: - General Version:
Keywords: Cc: alias.shop.cedric@…, siarzhuk
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

So it is on real hardware (laptop).

Tested with hrev28223 from haiku-files.org (I had the exact same problem some moths ago but didn't reported it).

Haiku is not responding to the keyboard (in Terminal,...) but if I press F12 then it goes to the KD and there the keyboard is working. Still no keyboard in Haiku after I typed 'co'. Even worse if I restart the computer then the keyboard is not working at all. I mean I can't enter in the BIOS neither in Windows or Linux. To get back the keyword I have to shutdown then unplug and remove the battery.

Change History (7)

comment:1 by cedric.be, 11 years ago

Cc: alias.shop.cedric@… added

Correction: after Haiku if I launch Windows the keyboard is working and if I reboot then I am again able to enter in the BIOS.

I tried with an USB keyboard, that one worked.

comment:2 by bbjimmy, 11 years ago

hrev28275 Terminal does not respond to the keyboard ... all other apps seem to respond ok. I can run svn-up and jam from shell scripts saved from StyledEdit after changing the permissions to execute and then double-clicking the file.

comment:3 by bbjimmy, 11 years ago

hrev28290 seems to work again

in reply to:  3 comment:4 by cedric.be, 11 years ago

Replying to bbjimmy:

hrev28290 seems to work again

I think your problem is not related to this issue. I tested again, with revision hrev28327 and the keyboard is still not responding except the 'F12' key.

comment:5 by siarzhuk, 8 years ago

Cc: siarzhuk added

comment:6 by siarzhuk, 8 years ago

Owner: changed from axeld to siarzhuk
Status: newin-progress

comment:7 by siarzhuk, 8 years ago

Resolution: fixed
Status: in-progressclosed

Fixed in hrev42325.

Note: See TracTickets for help on using tickets.