Opened 11 years ago

Closed 11 years ago

#2878 closed bug (fixed)

Setting the time with the Time preferences is broken.

Reported by: bga Owned by: julun
Priority: high Milestone: R1
Component: Preferences/Time & Date Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking: #3057
Has a Patch: no Platform: All

Description

If you try to adjust the time using the time preferences the behavior will be erratic. For example, select the minutes and start increasing it with the arrows and you will see that it will jump around and also change the time (not only the minutes).

Being able to enter the time by typing it instead of using the arrows would help too.

Attachments (1)

time.png (35.4 KB ) - added by bga 11 years ago.

Download all attachments as: .zip

Change History (14)

comment:1 by bga, 11 years ago

Component: - GeneralPreferences/Time & Date
Priority: normalhigh

comment:2 by anevilyak, 11 years ago

I just tried this...works perfectly here hrev28242.

comment:3 by bga, 11 years ago

Well, for me it seems completely messed up. For example I opened the time preferences to check again and although iy is 17:58 right now (thats what Deskbar's clock shows), time preferences opened showing a completely different time (something around 03:00). In fact, the display just changed and is now showing garbage (see attached screenshot).

by bga, 11 years ago

Attachment: time.png added

comment:4 by bga, 11 years ago

Also notice that the analog clock is showing the wrong time too. It was almost 6 PM when the screenshot was taken. Also, again, Deskbar's clock did show the correct time. Only tiem preferences seems to be messed up.

comment:5 by bga, 11 years ago

Hmmm... I opened it yet agaon and now it was correct. After a reboot, it was messed up again. Seems it is only the first time after boot that gets the date wrong.

comment:6 by halku, 11 years ago

I have a very similar situation with setting time. My situation is as described for this bug except meaningful hour and minute imformation is still displayed though inaccurate. The hours jump around as described when I try to change the minutes or the minutes jump around when I try to change the hours. I work around this by temporarily setting to GMT then once set going back to local time. I have noticed this in the last two prealpha versions I tried: hrev28350 and hrev28327.

comment:7 by mmlr, 11 years ago

Blocking: 3057 added

(In #3057) Duplicate of #2878.

comment:8 by scottmc, 11 years ago

It's broken for me on hrev28344. If I change to minutes past 36 minutes it jumps to 00. Also when I changed the time zone from Greenwich to Pacific the time showed as 4:-33AM, I don't recall time ever being negative before...

comment:9 by anevilyak, 11 years ago

Owner: changed from axeld to julun

This is most likely related to julun's time changes...

comment:10 by RandomInsano, 11 years ago

I'm refactoring /preferences/time/DateTimeEdit.cpp for something to do. I think the issue might be tied to "TTimeEdit::_CheckRange()" checking the hour instead of minutes or some such. The code there is a bit ugly, so here's hoping I can improve it a tad :P

I'd love to talk to Julun, so if he'd e-mail me it'd be swell (EdwinGuy@GMail.com).

comment:11 by julun, 11 years ago

I will look into the time implementation, didn't see anything obvious right now.

comment:12 by julun, 11 years ago

Status: newassigned

I can reproduce it sometimes, looking into it.

comment:13 by julun, 11 years ago

Resolution: fixed
Status: assignedclosed

Should be fixed as of hrev28524.

Note: See TracTickets for help on using tickets.