Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#3057 closed bug (duplicate)

Time & Date: Changing clock's minutes is VERY broken

Reported by: RandomInsano Owned by: axeld
Priority: normal Milestone: R1
Component: Preferences/Time & Date Version: R1/pre-alpha1
Keywords: Cc: edwinguy+haiku@…
Blocked By: #2878 Blocking:
Has a Patch: no Platform: All

Description

So, everyone's changing their clocks around here for daylight savings time, me included. The only problem is that when you do this, the hours and minutes change at the same time or the hours just jump all over the place.

Steps to reproduce: Right click clock to change time, scroll your minutes around until they cycle back to 60. While on the way the hours and sometimes the days will just jump all over the place. I'm now two days in the past!

This occurs on real and emulated hardware on builds up to hrev28470 at least.

Change History (2)

comment:1 Changed 11 years ago by mmlr

Blocked By: 2878 added
Resolution: duplicate
Status: newclosed

Duplicate of #2878.

comment:2 Changed 11 years ago by julun

Should be fixed as of hrev28524.

Note: See TracTickets for help on using tickets.