Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#294 closed bug (fixed)

BSlider behavor

Reported by: diver Owned by: axeld
Priority: normal Milestone: R1
Component: Applications Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Try to open Diskprobe with some file and drag slider to the right outside diskprobe window. Slider will come back to it's 1st position, but should be in the end of that scale.

Change History (8)

comment:1 Changed 13 years ago by jackburton

Summary: BSlider behavor BSlider behavor

comment:2 Changed 13 years ago by jackburton

Component: KitsApplications

comment:3 Changed 13 years ago by jackburton

The int32 used for SetValue() overflows, that's all. It's not a bug in BSlider.

comment:4 Changed 13 years ago by jackburton

Owner: changed from jackburton to axeld

comment:5 Changed 13 years ago by axeld

Status: newclosed

comment:6 Changed 13 years ago by axeld

Resolution: fixed

comment:7 Changed 13 years ago by axeld

It was a bug in BSlider - almost naturally, since it worked perfectly fine in R5 :) You were right though, the int32 got too big, but not from DiskProbe, but from BSlider::ValueForPoint() which did not work correctly for these large values. Fixed in hrev16839.

comment:8 Changed 13 years ago by korli

bug_group: developers
Note: See TracTickets for help on using tickets.