Opened 11 years ago

Closed 10 years ago

#2941 closed bug (invalid)

Can't open the Welcome html file with duble click in pre-alpha1

Reported by: miqlas Owned by: axeld
Priority: normal Milestone: R1
Component: Applications Version: R1/pre-alpha1
Keywords: Cc: mdisreali@…
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

Can't open the Welcome html file with duble click. The firefox starts, but it not load the welcome page.

Change History (10)

comment:1 Changed 11 years ago by scottmc

This has probably the same cause as http://dev.haiku-os.org/ticket/2876

comment:2 Changed 10 years ago by mmadia

Works for me with BeZillaBrowser. can this be closed?

comment:3 Changed 10 years ago by Adek336

I think the problem can only be reproduced if BeZillaBrowser hasn't been launched prior to attempting to load the welcome page.

comment:4 Changed 10 years ago by mmadia

right, I didn't consider the first launch without profile. Could you create this ticket at HaikuPorts and then request ticket to be closed?

comment:5 Changed 10 years ago by Disreali

The file /boot/beos/documentation/welcome/welcome.html has the incorrect MIME type. It is a 'text/plain' file type instead of a 'text/html' file type. One of the first things I do when test daily images is to manually change the MIME file type. As of hrev29796 the files MIME type is still not ideal. Once I change the mime type Bezilla open fine, only it opens two separate windows, but that is most likely a separate issue.

Changing how the build process assigns the file type in the image would help. I have no clue how it would be done, but I'm sure someone does.

comment:6 Changed 10 years ago by Disreali

Cc: mdisreali@… added

comment:7 in reply to:  5 Changed 10 years ago by idefix

Replying to Disreali:

The file /boot/beos/documentation/welcome/welcome.html has the incorrect MIME type. It is a 'text/plain' file type instead of a 'text/html' file type.

That problem is tracked in ticket:3610.

comment:8 Changed 10 years ago by scottmc

Has this one been fixed?

comment:9 Changed 10 years ago by humdinger

I just built an alpha-vmware image of hrev32435 and the welcome page will still not load on doubleclick when BeZilla wasn't launched before. BeZilla then comes up with it's normal home page. After that first launch, everything's fine.

It really is a ticket for BeZilla at HaikuPorts, I think. Maybe someone could open a ticket there and close this one? I don't want to cause too much work by requesting to register via manual email just to report this one thing.

comment:10 Changed 10 years ago by mmadia

Resolution: invalid
Status: newclosed

Tracked at OSDrawer : http://dev.osdrawer.net/issues/410 Closing invalid.

Note: See TracTickets for help on using tickets.