Opened 10 years ago

Closed 10 years ago

#2962 closed bug (fixed)

clicking rec button in Soundrecorder crashes it, only with 24 bit input

Reported by: nutela Owned by: korli
Priority: normal Milestone: R1
Component: Applications/SoundRecorder Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

rev 28288

# how to reproduce click rec button # experienced behavior soundrecorder crashes # expected behavior shouldn't crash

Change History (8)

comment:1 Changed 10 years ago by nutela

Component: - GeneralApplications/SoundRecorder
Owner: changed from axeld to korli
Platform: Allx86

GNU gdb 6.3 Copyright 2004 Free Software Foundation, Inc. GDB is free software, covered by the GNU General Public License, and you are welcome to change it and/or distribute copies of it under certain conditions. Type "show copying" to see the conditions. There is absolutely no warranty for GDB. Type "show warranty" for details. This GDB was configured as "i586-pc-haiku"...(no debugging symbols found)

[tcsetpgrp failed in terminal_inferior: Invalid Argument] Reading symbols from /boot/beos/system/runtime_loader...done. Loaded symbols for /boot/beos/system/runtime_loader Reading symbols from /boot/beos/system/lib/libbe.so...done. Loaded symbols for /boot/beos/system/lib/libbe.so Reading symbols from /boot/beos/system/lib/libmedia.so...done. Loaded symbols for /boot/beos/system/lib/libmedia.so Reading symbols from /boot/beos/system/lib/libtracker.so...done. Loaded symbols for /boot/beos/system/lib/libtracker.so Reading symbols from /boot/beos/system/lib/libstdc++.hrev4.so...done. Loaded symbols for /boot/beos/system/lib/libstdc++.hrev4.so Reading symbols from /boot/beos/system/lib/libroot.so...done. Loaded symbols for /boot/beos/system/lib/libroot.so Reading symbols from /boot/beos/system/lib/libtranslation.so...done. Loaded symbols for /boot/beos/system/lib/libtranslation.so Reading symbols from /boot/beos/system/lib/libtextencoding.so...done. Loaded symbols for /boot/beos/system/lib/libtextencoding.so [tcsetpgrp failed in terminal_inferior: Invalid Argument] [Switching to team /boot/beos/apps/SoundRecorder (1953) thread SoundRecorder (1953)] 0xffff0104 in ?? () (gdb) bt #0 0xffff0104 in ?? () #1 0x007685be in port_buffer_size_etc () from /boot/beos/system/lib/libroot.so #2 0x002e79de in BLooper::ReadRawFromPort ()

from /boot/beos/system/lib/libbe.so

#3 0x002e7a6a in BLooper::ReadMessageFromPort ()

from /boot/beos/system/lib/libbe.so

#4 0x002e713b in BLooper::MessageFromPort ()

from /boot/beos/system/lib/libbe.so

#5 0x002e7c03 in BLooper::task_looper () from /boot/beos/system/lib/libbe.so #6 0x002db9fa in BApplication::Run () from /boot/beos/system/lib/libbe.so #7 0x00213046 in main () (gdb)

comment:2 Changed 10 years ago by nutela

This happens when driver is set to 24 bit 96kHz, at 16 bit 48kHz recording works but is garbled (known problem, as on R5) @ korli: Could you fix this? I need to record for an entrance exam. Is recording working 100% ok on your Gina3g? If yes I'll buy one right away. Can send you the Mia Midi for testing if you wish.

comment:3 Changed 10 years ago by nutela

Yes! Recording at 16 bit, 44,1kHz works, and not garbled! Must be a resampling problem, only an occasional click is recorded but this is also with playback, something is interrupting the audio stream.

I will set put this info to the recording bug as well, must build and test this on R5. IIRC recording 16@44,1 would be garbled as well.

comment:4 Changed 10 years ago by korli

It could be a duplicate of #2805

comment:5 Changed 10 years ago by korli

Nutela, each time GDB comes up, if the stack trace is about BLooper::ReadRawFromPort (), could you type 'cont', it should stop on the real crashing thread ? It would help to find the problem encountered.

comment:6 Changed 10 years ago by nutela


0xffff0104 in ?? ()
(gdb) bt
#0  0xffff0104 in ?? ()
#1  0x00765526 in debugger () from /boot/beos/system/lib/libroot.so
#2  0x0076eb01 in __assert_fail () from /boot/beos/system/lib/libroot.so
#3  0x00219555 in RecorderWindow::RecordFile ()
#4  0x0021b83e in SoundConsumer::BufferReceived ()
#5  0x004bc2de in BBufferConsumer::HandleMessage ()
   from /boot/beos/system/lib/libmedia.so
#6  0x0021b41a in SoundConsumer::HandleMessage ()
#7  0x0021be7c in SoundConsumer::ServiceThread ()
#8  0x0021bcff in SoundConsumer::ThreadEntry ()
#9  0x00769c08 in thread_entry () from /boot/beos/system/lib/libroot.so
#10 0x70080fec in ?? ()

comment:7 Changed 10 years ago by nutela

Summary: clicking rec button in Soundrecorder crashes itclicking rec button in Soundrecorder crashes it, only with 24 bit input

comment:8 Changed 10 years ago by korli

Resolution: fixed
Status: newclosed

Should be fixed in hrev31760

Note: See TracTickets for help on using tickets.