Opened 11 years ago

Closed 10 years ago

#2805 closed bug (fixed)

Tracker crashes after extracting files from an archive

Reported by: scottmc Owned by: axeld
Priority: critical Milestone: R1/alpha1
Component: Applications/Tracker Version: R1/pre-alpha1
Keywords: Cc: olive@…
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I've seen this happen with recent builds for a week or so now. Could be something wrong in my build setup. Currently running hrev27878, with ata bus driver enabled and all optional packages installed, I've only checked in vmware so far. It's also been crashing when I try to right-click and delete folders. Here's the gdb output:

GNU gdb 6.3
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i586-pc-haiku"...(no debugging symbols found)

[tcsetpgrp failed in terminal_inferior: Invalid Argument]
Reading symbols from /boot/beos/system/runtime_loader...done.
Loaded symbols for /boot/beos/system/runtime_loader
Reading symbols from /boot/beos/system/lib/libbe.so...done.
Loaded symbols for /boot/beos/system/lib/libbe.so
Reading symbols from /boot/beos/system/lib/libtracker.so...done.
Loaded symbols for /boot/beos/system/lib/libtracker.so
Reading symbols from /boot/beos/system/lib/libroot.so...done.
Loaded symbols for /boot/beos/system/lib/libroot.so
Reading symbols from /boot/beos/system/lib/libstdc++.r4.so...done.
Loaded symbols for /boot/beos/system/lib/libstdc++.r4.so
Reading symbols from /boot/beos/system/lib/libtranslation.so...done.
Loaded symbols for /boot/beos/system/lib/libtranslation.so
Reading symbols from /boot/beos/system/lib/libtextencoding.so...done.
Loaded symbols for /boot/beos/system/lib/libtextencoding.so
Reading symbols from /boot/beos/system/add-ons/Translators/BMPTranslator...done.
Loaded symbols for /boot/beos/system/add-ons/Translators/BMPTranslator
Reading symbols from /boot/beos/system/add-ons/Translators/EXRTranslator...done.
Loaded symbols for /boot/beos/system/add-ons/Translators/EXRTranslator
Reading symbols from /boot/beos/system/lib/libilmimf.so...done.
Loaded symbols for /boot/beos/system/lib/libilmimf.so
Reading symbols from /boot/beos/system/lib/libz.so...done.
Loaded symbols for /boot/beos/system/lib/libz.so
Reading symbols from /boot/beos/system/add-ons/Translators/GIFTranslator...done.
Loaded symbols for /boot/beos/system/add-ons/Translators/GIFTranslator
Reading symbols from /boot/beos/system/add-ons/Translators/JPEG2000Translator...done.
Loaded symbols for /boot/beos/system/add-ons/Translators/JPEG2000Translator
Reading symbols from /boot/beos/system/add-ons/Translators/JPEGTranslator...done.
Loaded symbols for /boot/beos/system/add-ons/Translators/JPEGTranslator
Reading symbols from /boot/beos/system/add-ons/Translators/PCXTranslator...done.
Loaded symbols for /boot/beos/system/add-ons/Translators/PCXTranslator
Reading symbols from /boot/beos/system/add-ons/Translators/PNGTranslator...done.
Loaded symbols for /boot/beos/system/add-ons/Translators/PNGTranslator
Reading symbols from /boot/beos/system/add-ons/Translators/PPMTranslator...done.
Loaded symbols for /boot/beos/system/add-ons/Translators/PPMTranslator
Reading symbols from /boot/beos/system/add-ons/Translators/RAWTranslator...done.
Loaded symbols for /boot/beos/system/add-ons/Translators/RAWTranslator
Reading symbols from /boot/beos/system/add-ons/Translators/RTF-Translator...done.
Loaded symbols for /boot/beos/system/add-ons/Translators/RTF-Translator
Reading symbols from /boot/beos/system/add-ons/Translators/SGITranslator...done.
Loaded symbols for /boot/beos/system/add-ons/Translators/SGITranslator
Reading symbols from /boot/beos/system/add-ons/Translators/STXTTranslator...done.
Loaded symbols for /boot/beos/system/add-ons/Translators/STXTTranslator
Reading symbols from /boot/beos/system/add-ons/Translators/TGATranslator...done.
Loaded symbols for /boot/beos/system/add-ons/Translators/TGATranslator
Reading symbols from /boot/beos/system/add-ons/Translators/TIFFTranslator...done.
Loaded symbols for /boot/beos/system/add-ons/Translators/TIFFTranslator
Reading symbols from /boot/beos/system/add-ons/Translators/WonderBrushTranslator...done.
Loaded symbols for /boot/beos/system/add-ons/Translators/WonderBrushTranslator
[tcsetpgrp failed in terminal_inferior: Invalid Argument]
[Switching to team /boot/beos/system/Tracker (76) thread Tracker (76)]
0xffff0104 in ?? ()
(gdb) bt
#0  0xffff0104 in ?? ()
#1  0x006581fa in port_buffer_size_etc () from /boot/beos/system/lib/libroot.so
#2  0x002b2302 in BLooper::ReadRawFromPort ()
   from /boot/beos/system/lib/libbe.so
#3  0x002b238e in BLooper::ReadMessageFromPort ()
   from /boot/beos/system/lib/libbe.so
#4  0x002b1a2b in BLooper::MessageFromPort ()
   from /boot/beos/system/lib/libbe.so
#5  0x002b251b in BLooper::task_looper () from /boot/beos/system/lib/libbe.so
#6  0x002a6685 in BApplication::Run () from /boot/beos/system/lib/libbe.so
#7  0x002009eb in main ()
(gdb) 

Attachments (2)

screen-tracker-mails (58.8 KB) - added by VinDuv 11 years ago.
Glteapot_gdb_r28231.txt (2.1 KB) - added by aldeck 11 years ago.

Download all attachments as: .zip

Change History (16)

comment:1 Changed 11 years ago by anevilyak

Component: - GeneralApplications/Tracker

Can you check if it happens with 27868? 27869 and 27870 had some tracker changes.

comment:2 Changed 11 years ago by jackburton

I've seen this happen once or twice, but in different situations: once while using the NavMenus in Tracker, and once with GLTeapot. It's been a while though. Last time I saw it was at Pianeta Amiga (I had updated my local copy on September 26).

comment:3 Changed 11 years ago by aldeck

Can you retry? There was a bug causing a similar crash in Tracker that was fixed yesterday. It was happening simply by creating a folder and moving it back and forth to/from another directory. See hrev28015. It might be unrelated though.

comment:4 Changed 11 years ago by VinDuv

I got the same crash when trying to sort a mail folder (with the "When" column). hrev28232.

#0  0xffff0104 in ?? ()
#1  0x0066532a in port_buffer_size_etc () from /boot/beos/system/lib/libroot.so
#2  0x002b5dce in BLooper::ReadRawFromPort ()
   from /boot/beos/system/lib/libbe.so
#3  0x002b5e5a in BLooper::ReadMessageFromPort ()
   from /boot/beos/system/lib/libbe.so
#4  0x002b54f7 in BLooper::MessageFromPort ()
   from /boot/beos/system/lib/libbe.so
#5  0x002b5fe7 in BLooper::task_looper () from /boot/beos/system/lib/libbe.so
#6  0x002a9899 in BApplication::Run () from /boot/beos/system/lib/libbe.so
#7  0x002009eb in main ()

Folder screenshot attached (hopefully).

Changed 11 years ago by VinDuv

Attachment: screen-tracker-mails added

comment:5 Changed 11 years ago by korli

Got it several times with GLTeapot today: best to reproduce is moving around the GLTeapot window very fast: seems to happen very often with 2 CPUs

comment:6 Changed 11 years ago by korli

Milestone: R1R1/alpha1
Priority: normalcritical

comment:7 Changed 11 years ago by jackburton

Yeah, I too was able to reproduce it this way, some time ago, but not recently. Should not be a tracker problem anyway, but rather a BLooper / BMessage related.

comment:8 Changed 11 years ago by aldeck

well, iirc, this kind of backtrace can be caused by pretty much everything.

As for the GLTeapot test, i think it's a different bug. I can crash glteapot/gldirectmode just by moving the window here on real hardware 2 cpus hrev28231, vesa. And i get either this kind of backtrace or a segfault in MesaSoftwareRenderer::SwapBuffers(). Korli, do you think it might be due to the last update to mesa?

backtrace follows

Changed 11 years ago by aldeck

Attachment: Glteapot_gdb_r28231.txt added

comment:9 Changed 11 years ago by aldeck

replying to myself: "well, iirc, this kind of backtrace can be caused by pretty much everything." see #2956

comment:10 Changed 10 years ago by karmak

Cc: olive@… added

Hi, I think I've got a valid backtrace ; when trying to sort my mail/in folder (3100+ messages inside) by subject, i've got this one (on real hardware, hrev28734):

#0  0x003bef0a in BList::ItemAt () from /boot/beos/system/lib/libbe.so
#1  0x0057a3ed in BPrivate::BPose::WidgetFor ()
   from /boot/beos/system/lib/libtracker.so
#2  0x00599432 in PoseCompareAddWidget ()
   from /boot/beos/system/lib/libtracker.so
#3  0x0059e5fb in PoseCompareAddWidgetBinder ()
   from /boot/beos/system/lib/libtracker.so
#4  0x003c5faf in PointerListHelperWithState::Compare ()
   from /boot/beos/system/lib/libbe.so
#5  0x003c5989 in void ** __unguarded_partition<void **, void *, comparator> ()
   from /boot/beos/system/lib/libbe.so
#6  0x003c5b22 in void __introsort_loop<void **, void *, long, comparator> ()
   from /boot/beos/system/lib/libbe.so
#7  0x003bf7c4 in AbstractPointerListHelper::QuickSort ()
   from /boot/beos/system/lib/libbe.so
#8  0x003bf666 in AbstractPointerListHelper::SortItems ()
   from /boot/beos/system/lib/libbe.so
#9  0x003bf9cf in _PointerList_::SortItems ()
   from /boot/beos/system/lib/libbe.so
#10 0x0059d363 in BObjectList<BPrivate::BPose>::SortItems ()
   from /boot/beos/system/lib/libtracker.so
#11 0x00599791 in BPrivate::BPoseView::SortPoses ()
   from /boot/beos/system/lib/libtracker.so
#12 0x005bc3af in BPrivate::ColumnDragState::Clicked ()
---Type <return> to continue, or q <return> to quit---
   from /boot/beos/system/lib/libtracker.so
#13 0x005bb901 in BPrivate::ColumnTrackState::MouseUp ()
   from /boot/beos/system/lib/libtracker.so
#14 0x005bafe8 in BPrivate::BTitleView::MouseUp ()
   from /boot/beos/system/lib/libtracker.so
#15 0x00360ae1 in BWindow::DispatchMessage ()
   from /boot/beos/system/lib/libbe.so
#16 0x00364e4f in BWindow::task_looper () from /boot/beos/system/lib/libbe.so
#17 0x002b60cf in BLooper::_task0_ () from /boot/beos/system/lib/libbe.so
#18 0x00668640 in thread_entry () from /boot/beos/system/lib/libroot.so
#19 0x701c5fec in ?? ()

comment:11 in reply to:  10 Changed 10 years ago by aldeck

To karmak: the backtrace you had was due to another problem fixed in hrev28871 :)

To scottmc: could you recheck? as there has been a few tracker fixes recently.

Thanks for testing.

PS: the GLTeapot bug was fixed a few weeks ago too.

comment:12 Changed 10 years ago by scottmc

I can't say that I've seen this happen in the past 2 months, and I use Haiku for a few hours each day usually. So if there's been fixes to tracker recently that probably fixed it. Can close.

comment:13 Changed 10 years ago by karmak

I noticed the fix (i'm on the mailing list). Thanks !!

comment:14 Changed 10 years ago by aldeck

Resolution: fixed
Status: newclosed

Ok, please reopen if you see it again!

Note: See TracTickets for help on using tickets.