Opened 10 years ago

Closed 6 months ago

#2976 closed bug (fixed)

Email preferences character problem

Reported by: miqlas Owned by: axeld
Priority: normal Milestone: R1
Component: Kits/Interface Kit Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

I can write Hungarian letter to the textboxes, I have problem only the "á" character. This width don't calculated correctly, i think, because the caracters overlaping this character. Check the screenshot. Haiku R28283

Attachments (1)

Email_character_problems.jpg (53.8 KB) - added by miqlas 10 years ago.
Email preferences character problems

Download all attachments as: .zip

Change History (10)

Changed 10 years ago by miqlas

Email preferences character problems

comment:1 Changed 10 years ago by axeld

And this is supposed to be specific to E-Mail, and is not reproducible with StyledEdit, Tracker, etc.? Are you sure it's not a general problem with that character???

Have you tried if using another font helps? It could very well be a problem of the font we're using.

comment:2 Changed 10 years ago by miqlas

Axel, this is why You are the best.. :) Yeah, You have right, sorry, i don't tested it in another program, but i will test it, and i will put a comment here, ok? Sorry again, i forget it.

comment:3 Changed 10 years ago by miqlas

Sorry, but i can't reproduce this problem. I tested, now everything fine, but i don't change anything. (Before the last reboot i select bigger font to check the application, and i set back to default (Same font, same size), and now its fine.

comment:4 Changed 10 years ago by stippi

Hm. Please don't close the ticket though, it may point to a problem in the BTextView::WidthBuffer implementation. In that case, it also wouldn't be visible in more than one application at the same time, since the WidthBuffer is application global, but not system global.

comment:5 Changed 10 years ago by axeld

That makes sense indeed, thanks for the update!

comment:6 Changed 10 years ago by jackburton

There is a simple test for WidthBuffer in src/tests/kits/interface/WidthBufferTest.cpp. I used it once to track down some bugs in it. Maybe it could be extended.

comment:7 Changed 7 years ago by diver

Component: User InterfaceKits/Interface Kit
Owner: changed from stippi to axeld

comment:8 Changed 6 years ago by miqlas

Checked on hrev46130 : everything fine, You can close this ticket, if there is nothing else. Thanks!

comment:9 Changed 6 months ago by waddlesplash

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.