Opened 11 years ago

Closed 10 years ago

#2975 closed bug (fixed)

Tracker, some items not properly redrawn in list mode

Reported by: miqlas Owned by: nobody
Priority: normal Milestone: R1
Component: Applications/Tracker Version: R1/pre-alpha1
Keywords: Cc: adek336@…
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

In R28283 I opened the Tracker, and i see the filename at the bottom of the window not drawed correctly. Check the screenshot.

Attachments (2)

Tracker_redraw_problem.jpg (105.7 KB) - added by miqlas 11 years ago.
Tracker redraw problem
tracker_redraw_problem_2.jpg (30.8 KB) - added by miqlas 11 years ago.

Download all attachments as: .zip

Change History (12)

Changed 11 years ago by miqlas

Attachment: Tracker_redraw_problem.jpg added

Tracker redraw problem

Changed 11 years ago by miqlas

comment:1 Changed 11 years ago by aldeck

Component: User InterfaceApplications/Tracker
Owner: changed from stippi to aldeck
Status: newassigned
Summary: Tracker redraw problemTracker, some items not properly redrawn in list mode

I believe the problem in the second screenshot is related to #1816, herdemir sent a patch that fixes it.

As for the first screenshot, i know the problem or a very similar one and could see it mostly in some populated folder ex: /beos/bin, some of the items have the same redraw problem (and not necessarily the last item).

This happens only in list mode for what i've seen.

Not totally sure it's a Tracker problem, but it most probably is, changing component. I'll have a look at the same time as #1816, accepting the ticket.

comment:2 Changed 11 years ago by anevilyak

Did you ever make any headway with this one aldeck? If not, would you like me to look at it?

comment:3 in reply to:  2 Changed 11 years ago by aldeck

Owner: changed from aldeck to nobody
Status: assignednew

Replying to anevilyak:

Did you ever make any headway with this one aldeck? If not, would you like me to look at it?

Go ahead Rene :) Sorry for the late reply, i was in vacation!
IIRC it ended unrelated to the other bugs i mentioned.

comment:4 Changed 10 years ago by Adek336

Cc: adek336@… added

comment:5 Changed 10 years ago by Adek336

To reproduce problem 2, open a folder under the Haiku generated files, say, generated/.../add-ons/kernel/network/stack, delete one of the files, sort by newest on top, make the window small so that the vertical scrollbar appears, scroll to somewhere near the bottom, in the background do jam -q in src/add-ons/kernel/network/stack directory, click on the vertical scrollbar in Tracker window, start moving it slowly a little up and down. While the folder contents are updated, problem 2 is reproduced.

comment:6 Changed 10 years ago by Adek336

comment:7 in reply to:  4 Changed 10 years ago by aldeck

Replying to [Adek336]:

If you mean the problem in screenshot 2, it was already tracked in #1849. I admit it's not clear from the previous comments. There was a confusion between several bugs a few month ago. This ticket should only refer to the bug seen in screenshot 1.

Regards.

comment:8 Changed 10 years ago by Adek336

Ok, thanks for the note!

comment:9 Changed 10 years ago by stippi

#1849 is a different problem, but the problem from the first screen shot could be fixed in hrev30033.

comment:10 Changed 10 years ago by stippi

Resolution: fixed
Status: newclosed

Maybe fixed in hrev30068. The first screenshot doesn't look like the problem I fixed, but there is a good chance it's the probblem already fixed in one of my earlier commits. I am closing this, but please reopen if you see it again.

Note: See TracTickets for help on using tickets.