Opened 11 years ago

Closed 11 years ago

#2999 closed bug (duplicate)

System deadlock when connecting USB devices with ipro100 driver

Reported by: RandomInsano Owned by: axeld
Priority: normal Milestone: R1
Component: Drivers/Network Version: R1/pre-alpha1
Keywords: Cc: edwinguy+haiku@…
Blocked By: #2048 Blocking:
Has a Patch: no Platform: x86

Description

When I plug in any device into my Compaq Armada M700s USB port the system gets stuck in the fpx interrupt handler during boot (I can see this by getting into the KDL with F12) and the system completely locks up if I do this once the system is booted.

Unplugging the device again doesn't bring the system back into a usable state and it doesn't matter what class of device I use (Several Mass Storage devices, Mouse, Keyboard, Ethernet have been tested).

If I delete the ipro100 device driver the system no longer has this problem, though there are further problems with trying to mount USB mass storage as writable, but that's another story.

The problem also exists on an old Compaq Deskpro. I've tested with many revisions up to 28350 and have never had luck with using USB devices on either system.

Attachments (3)

DSCN2404.JPG (145.5 KB ) - added by RandomInsano 11 years ago.
Sticking Point
DSCN2405.JPG (151.7 KB ) - added by RandomInsano 11 years ago.
KDL Launched
DSCN2406.JPG (164.4 KB ) - added by RandomInsano 11 years ago.
KDL Threads

Download all attachments as: .zip

Change History (8)

by RandomInsano, 11 years ago

Attachment: DSCN2404.JPG added

Sticking Point

by RandomInsano, 11 years ago

Attachment: DSCN2405.JPG added

KDL Launched

by RandomInsano, 11 years ago

Attachment: DSCN2406.JPG added

KDL Threads

comment:1 by axeld, 11 years ago

Component: DriversDrivers/Network

It's the ipro100 driver with each system? Also, the "ints" KDL command would be helpful, too.

comment:2 by umccullough, 11 years ago

At least the ipro100 problem is already reported in #2084 for reference.

comment:3 by RandomInsano, 11 years ago

It is the ipro100 driver in both. The issue is only when USB devices are attached however, so perhaps I'll just add my information to bug #2084 instead

comment:4 by RandomInsano, 11 years ago

This does appear to be a duplicate bug. I'm copying my information over to bug #2084

comment:5 by axeld, 11 years ago

Blocked By: 2048 added
Resolution: duplicate
Status: newclosed

No need to, I just mark this as a duplicate.

Note: See TracTickets for help on using tickets.