Opened 11 years ago

Closed 8 years ago

#3008 closed bug (fixed)

MacBook iSight: More than 99% interrupts of vector 9 are unhandled

Reported by: aljen Owned by: mmlr
Priority: normal Milestone: R1
Component: Drivers/USB Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

In Parallels, when Haiku(hrev28388) is running and i connect macbook embeded webcam (Parallels 'Devices' menu -> USB -> Built-in iSight), system freezes:

[syslog snip]

USB Hub 1: port 0: status: 0x0101; change: 0x0001
USB Hub 1: device at port 0: 0x00000000
usb_ehci_roothub: request: 1
usb_ehci_roothub: clear feature: 16
USB Hub 1: new device connected
usb_ehci_roothub: request: 3
usb_ehci_roothub: set feature: 4
usb_ehci: reset port 0
usb_ehci_roothub: request: 0
usb_ehci_roothub: request: 1
usb_ehci_roothub: clear feature: 20
USB Hub 1: port 0 was reset successfully
usb_ehci_roothub: request: 0
USB BusManager: setting device address to 2
usb_ehci: pipe change 0 for pipe 0x80f93780
usb_ehci: wrote descriptor chain (8 bytes, no more vectors)
usb_ehci: linking queue
queue:    t03914180 n00000001 ch30086000 ca40000000 cu00000001
overlay:  n03914280 a00000001 t00000000 00000000 00000000 00000000 00000000 00000000
 03914280 n03914300 a03914200 t00080e80 03914060 03915000 03916000 03917000 03918000 s8
 03914300 n00000001 a00000001 t80008d80 00000000 00000000 00000000 00000000 00000000 s0
usb_ehci: transfer finished
usb_ehci: port change detected
More than 99% interrupts of vector 9 are unhandled

Change History (5)

comment:1 Changed 11 years ago by anevilyak

Is the USB controller by any chance sharing IRQs with another device in the system?

comment:2 Changed 11 years ago by aljen

I think it would be Parallels Bridge (vendor: 1ab8, device: 1112) on IRQ 9, attaching syslog

comment:3 Changed 11 years ago by aljen

eh can't attach file, trac error, syslog: http://hitomi.pl/haiku/syslog.txt

comment:4 Changed 8 years ago by luroh

If the problem is still an issue on a recent revision of Haiku, are you able to get into KDL (Alt-PrtSc-D) and provide the output of the 'ints' command?

comment:5 Changed 8 years ago by mmlr

Resolution: fixed
Status: newclosed

I'm going to close this. It's ancient, many things have been fixed in the meantime, IO-APICs might resolve this as well, there has been no feedback and the externally hosted syslog isn't available anymore either. Please reopen if this is still an issue and attach a fresh syslog and the suggested KDL ints output.

Note: See TracTickets for help on using tickets.